KDE Plasma crash

I recently installed openSuSE 11.1 on a ThinkPad T23 (P3 1133MHz, 1 GB RAM, KDE 4.1.3 release 4.9). In getting the CD-ROM to work, I found the forum advice at Cannot mount a CD-ROM - Page 2 - openSUSE Forums to add User to the cdrom and disk groups. I did that, and things worked. Then a subsequent posting said to not have User in the disk group, so I removed it. Since then I cannot run as normal User, only as root.
When I log-in as User, after the log-screen, the boot screen shows for about 10 seconds, then the screen goes white and a message window appears:
“Plasma Workspace - The KDE Crash Handler
A Fatal Error Occurred.
The application Plasma Workspace (plasma) crashed and caused a signal 11(SIGSEGV)…”

When I log-in as root, things seem normal. I put User back in disk group, but that made no difference.

fstab is:
/dev/disk/by-id/ata-ST96812A_3PJ1TEJY-part5 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-ST96812A_3PJ1TEJY-part6 /usr ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-ST96812A_3PJ1TEJY-part7 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-ST96812A_3PJ1TEJY-part8 /var ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-ST96812A_3PJ1TEJY-part9 /tmp ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-ST96812A_3PJ1TEJY-part10 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/disk/by-id/ata-ST96812A_3PJ1TEJY-part1 /win/c ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-ST96812A_3PJ1TEJY-part2 /win/d vfat users,gid=users,umask=0002,utf8=true 0 0

mtab is:
/dev/sda5 / ext3 rw,acl,user_xattr 0 0
/proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/sda6 /usr ext3 rw,acl,user_xattr 0 0
/dev/sda7 /home ext3 rw,acl,user_xattr 0 0
/dev/sda8 /var ext3 rw,acl,user_xattr 0 0
/dev/sda9 /tmp ext3 rw,acl,user_xattr 0 0
/dev/sda1 /win/c fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
/dev/sda2 /win/d vfat rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
securityfs /sys/kernel/security securityfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/sr0 /media/SU1110.001 iso9660 ro,nosuid,nodev,noatime,uid=0,utf8 0 0

I tried to “Repair installed system” from the DVD, but it just sat. Any ideas what went wrong, and how to fix it?

There is a lot of things…
First, do not log in as root. SDB:Graphical Login as Root - openSUSE. Many times root login leads to another problems and doesn’t solves anything.
I’m just added my user to disk and cdrom group because K3b issues.
The simplest solution would be renaming your users .kde4 directory to .kde4old. After try to log in with normal user.

Thanks, ram88, your simple solution worked to get me logged in as User. I have to customize the desktop again, but that is minor.
Best regards,

It takes less time to recustomize your desktop then guessing out from the log messages what is the problem. :wink: