KDE Plasma 5.6.90 update??????

I’m running the Plasma5 Frameworks5 repo and the Qt5 repo. Today, I did a zypper up and was presented with a huge update with 280 packages to upgrade. I approved the update and rebooted afterwards. The results were not good with the breeze login screen presenting an ugly blue login screen. So, I went into settings and the breeze login screen theme was not found or undefined (I don’t remember the exact wording but it was not there). Then, I noticed that the launcher did not work at all - completely FUBAR’d. My info center icon worked though and reported that I was running Plasma 5.6.90. In any event, I had backed up my system immediately before the update and so I immediately reverted to my backup which is working great.

So, my question is, what is going on with the Frameworks 5 repo? Here is the repo url:


FWIW, I have not touched any my repos in months so I am fairly confident that this was not caused by anything that I have done, at least recently.



I think the repo is OK :wink:
You got the beta version of Plasma 5.7. They changed the login and splash screen.
Please read: https://www.kde.org/announcements/plasma-5.6.95.php

login screen is ugly (my personal view) and “Agenda items in Calendar” does not work for me actually.

Kind regards

Take this as a warning sign. The KDE updates that appear through the Update repo ( yes, they do ) are just a tad behind upstream stable, and all these packages will only appear in those repos after succesful testing in openQA. Enabling repos like the ones you added is breaking that. Which ( very rarely, but still ) can come at a cost.
If you intend to actually test the beta packages, report bugs. If you want a stable system, either use Tumbleweed ( openQA tested as well ) or stick to the packages Leap serves.

Thanks Knurpht and alfaflo for your replies!

Knurpht, I successfully used the KDE4 repos with 13.1/13.2 and had been having a similar successful experience with the Plasma5/Frameworks5 repo on Leap 42.1 until now. I had no idea that beta versions of the Plasma 5.x software were now being pushed to these repos. So, I will revert back to the update repo ASAP as you recommended.

Thanks again,


No help at all but I did the same upddate using the latest iso of tumbelweed 13062016 and it worked fine. Do agree with you about the blue sddm screen.

There is nothing wrong with that update or the repo. I had the same update and while I dislike the upstream branding for sddm, and there is no image preview available, you can still select a background of your choice for it and change from the ugly blue colour.

The annoying part is the next splash directly after login still being blue and no way of changing that though.

The launcher must just be plasma corruption I would have thought.

No; I have it too after the same update. The application icons on the panel still work, but the launcher doesn’t; and the task manager notifications have also quit. The error message I get is this:

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/main.qml:27:1: plugin cannot be loaded for module “org.kde.plasma.private.kicker”: Cannot load library /usr/lib64/qt5/qml/org/kde/plasma/private/kicker/libkickerplugin.so: (libKF5ActivitiesStats.so.1: cannot open shared object file: No such file or directory)

Its a shame that something this buggy was posted to the Frameworks5 repo for Leap 42.1. I found it completely unusable.

I submitted a bug to the KDE folk, and they advise that:

this is a packaging/installation issue on your distro:
It looks like your Task Manager and Application Menu packages
were built against a different version of the ActivitiesStats
library from KDE Frameworks than you have installed.

… so I’ve re-submitted it all to the openSUSE folk.

OK; it turns out that the problem was that I had the
wrong version of the libKF5ActivitiesStats1 package installed.
Upon replacing it with version 5.23.0-9.1 from the official
…KDE:/Frameworks5/ repo, it fixed the problem.

So it wasn’t a packaging error as much as a PEBKAC error!

I downloaded the beta as soon as I saw it in the repos and, if anything, it’s working better than before for me. I’m even getting to quite like the breeze graphics, although I still prefer the oxygen icons.

The repo is still FUBAR’d. I just tried the 5.6.90 upgrade again and the launcher is completely broken with the following error message:

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/main.qml:27:1: plugin cannot be loaded for module "org.kde.plasma.private.kicker": Cannot load library /usr/lib64/qt5/qml/org/kde/plasma/private/kicker/

Other stuff is messed up too such as the task bar icons and the breeze theme not being found… not to mention the ugly login screen.

In its present state the 5.6.90 update is totally unusable.


Sure you are not mixing repos???

Hi gogalthorp,

Thanks for your reply!  Yep, you nailed it!... I had apparently mixed the repos up.  I did     a zypper dup as follows:

zypper dup --from <Frameworks5 repo> --from <Qt5 repo> --from <packman repo> 

and now everything appears to be working correctly. So, I must have somehow dumb thumbed the repos. Nevertheless, although everything works correctly now (such as the launcher, panel icons, etc) the breeze theme is now incomplete and the login screen and splash screens are ugly. The breeze theme for the login screen says “No preview available” although the overall theme is listed under “look and feel”. The OpenSUSE branding for the login and splash screens have apparently been replaced by KDE branding with an ugly blue background color.

Does anybody have any ideas on how to get the breeze login theme back with OpenSUSE branding?



Try swapping out sddm-branding-upstream for sddm-branding-opensuse in yast

Hi David,

Thanks for the suggestion, however, sddm-branding-OpenSUSE is already selected which is strange since the login screen and associated splash screen are NOT OpenSUSE branding but appear to be KDE branding instead.


when you switch out the openSUSE splash screen for the Breeze splash screen it actually looks kinda nice (imo).
The openSUSE splash screen does look a bit like it was thrown together a bit quickly to fit in with the changes. The gecko seems out of proportion and the greenish progress bar does not fit with the blue background.

When using the frameworks 5 repo though we need to expect these kinds of changes.
I’m sure the suse artwork team will have something completely openSUSE looking in the next Leap release (if not before).

Same here when I tried, I get the impression you have to swap out all the other upstream branding as well as sddm upstream, in order for it to work. Not worth it for me as I can change the background and put up with the following k-splash till something is done about it - there is a unified system due in 5.8 that unifies the whole thing from grub / Plymouth / SDDM / Ksplash / User Switch / Lock Screen / Shutdown apparently

Hi David,

I agree. I had already decided to just wait for 5.8 and stick with 5.6.4 until then but its comforting to hear that the complete UI will be unified with 5.8. Thanks for that info!


the original Leap 42.1 sddm branding is back in the Plasma 5.7 release