KDE Plamsa - Can't revert from Wayland to X11

Greetings all. In a test to see if Wayland was still giving me critical issues, I swapped to Wayland. Things were working fine, but small things like trying to use the scrollbar in LibreOffice, and MAME not supporting hardware acceleration with Wayland wasn’t to my liking. To my surprise, I now see two “Plasma (X11)” options. Selecting the first option only gives me tty, the second option boots into Plasma X11 normally, but upon reboot TW will default to the first Plasma X11 option and send me to tty, rendering me unable to switch back to X11.

At a huge loss here of how to resolve this, but I assume it’s going to involve removing the “bad” session entries. I suppose a temporary solution would be to remove the auto-login and manually select the second X11 entry each time, but if I’m thrown to tty, I can’t get to that screen.

$ ll /usr/share/xsessions/*
lrwxrwxrwx 1 root root   42 May 28 20:15 /usr/share/xsessions/default.desktop -> /etc/alternatives/default-xsession.desktop
lrwxrwxrwx 1 root root   15 May 28 20:17 /usr/share/xsessions/kde-plasma.desktop -> plasma5.desktop
-rw-r--r-- 1 root root 3.2K May 28 20:05 /usr/share/xsessions/plasma5.desktop
$ sudo update-alternatives --query default-xsession.desktop
Name: default-xsession.desktop
Link: /usr/share/xsessions/default.desktop
Status: auto
Best: /usr/share/xsessions/plasma5.desktop
Value: /usr/share/xsessions/plasma5.desktop

Alternative: /usr/share/xsessions/plasma5.desktop
Priority: 25

It’s possible the relative link is confusing SDDM. There might be a bug or two in this configuration page too (it should perhaps show KDE Plasma (default) instead of duplicates, and be able to set the correct session). You can set the default session with update-alternatives or using YaST Alternatives, just set default-xsession.desktop to /usr/share/xsessions/plasma5.desktop

1 Like

Interestingly, default-xsession.desktop is set to /usr/share/xsessions/plasma5.desktop.

Output of ll /usr/share/xsessions/*

lrwxrwxrwx 1 root root   42 May 12 17:45 /usr/share/xsessions/default.desktop -> /etc/alternatives/default-xsession.desktop
-rw-r--r-- 1 root root 3334 May 10 07:39 /usr/share/xsessions/icewm.desktop
lrwxrwxrwx 1 root root   13 May 10 07:39 /usr/share/xsessions/icewm-session.desktop -> icewm.desktop
lrwxrwxrwx 1 root root   15 May 12 17:47 /usr/share/xsessions/kde-plasma.desktop -> plasma5.desktop
-rw-r--r-- 1 root root 3175 May 12 17:33 /usr/share/xsessions/plasma5.desktop

As I can no longer edit my post above, I have to create a new post for an update:

kde_settings.conf in /etc/sddm.conf.d/ shows Session=plasmawayland instead of plasma5.desktop which may have been an issue at some point? I will try backing it up and changing the session and rebooting.

For reference, my kde_settings.conf contains…


Ah thank you! I tried plasma5.desktop, plasma and plasma.desktop to no affect, but will now try default.desktop!

EDIT: Still booting into wayland, but I am going to leave Session=default.desktop for now and see if changing in SDDM to Plasma (X11) now doesn’t boot to tty. Will keep banging away at the issue. Sadly my snapshots are too old to revert to and my latest working snapshot is one day after switching to Wayland.

Are you using autologin? Can you not set the desired session from the SDDM login screen itself?

What does the following report?

sudo cat /var/lib/sddm/state.conf

Interesting observation: To workaround this auto-login issue, I’ve decided to try to disable the auto-login by unticking the checkbox and applying the settings. The settings apply and the Automatically log in: box is checked again and the Apply box being greyed out, meaning my settings had reverted and never applied…

EDIT: Looks like we both had similar thinking and posted at the same time, ha!


# Name of the last logged-in user.
# This user will be preselected when the login screen appears

# Name of the session for the last logged-in user.
# This session will be preselected when the login screen appears.

I seemingly can logout, choose X11, and log back in and X11 does become the compositor, however, I can not disable auto-login.

@asudem … might try this

Open the Yast2 User Admin. module
Select (highlight) your user entry
At bottom right of module, select “Expert Options”, Login Settings (screenshot)
At the pop-up, Un-check Auto Login, click OK
… Try again.


It is, bizarrely, already unchecked :thinking:

EDIT: Tried checking, applying, exiting, coming back and unchecking and applying to see if it would affect the SDDM setting, it didn’t.

1 Like

Compiling and launching sddm-conf reveals something interesting:
My session file list is as follows:

  • plasmawayland
  • default
  • icewm-session
  • icewm
  • kde-plasma
  • plasma5

There’s some duplication here but it’s unclear what caused it.

I have traced down the individual files, which @awerlang was spot on about.

  • plasmawayland (/usr/share/wayland-sessions/plasmawayland.desktop)
  • default (/usr/share/xsessions/default.desktop' is a link to/etc/alternatives/default-xsession.desktopwhich itself is a link to/usr/share/xsessions/plasma5.desktop`)
  • icewm-session (/usr/share/xsessions/icewm-session.desktop is a link to /usr/share/xsessions/icewm.desktop)
  • icewm (/usr/share/xsessions/icewm.desktop)
  • kde-plasma (/usr/share/xsessions/kde-plasma.desktop is a link to /usr/share/xsessions/plasma5.desktop)
  • plasma5 (/usr/share/xsessions/plasma5.desktop)

I am unsure if all of the links are necessary, but if anything all the linking points to plasma5 anyway if I just KDE X11. So picking and choosing any of the Plasma (X11) prompts should boot just fine. I will do this and attempt to look at the journal via tty to find any errors.

EDIT: Again, changing anything in SDDM would revert, so (X11) reverted to (Wayland) after applying, as if no settings had changed. I changed the setting via sddm-conf and checked SDDM again, and the (X11) seemed to apply. I will reboot, but I am very tempted to go way back in time and work forward from a snapshot where my configs worked properly and see if that fares better than where I am at currently.

Changing the settings in sddm-conf did work, but created a new login theme I didn’t like, so back to SDDM and I applied the the theme change and rebooted… it threw me into tty and then rebooted… Not wanting to risk whatever other configurations could be damaged on my computer, I decided to bite the bullet and restore a month old snapshot, prior to swapping to wayland. A zypper dup throws me to tty, but no reboot, so I decide to inspect the journal. It seems like ssdn Could not start Display server on vt 7 and coredumps me to tty, so again, I feel like sddm is still at play here. Even at my month old+ snapshot, trying to change from X11 to Wayland via SDDM immediately reverts any changes I try to apply.

What in the world is going on with my machine :confused:

Have you ever emptied ~/.cache/? Sometimes it fixes errant Plasma behavior. Must do it while not logged into Plasma.

I will give that a shot momentarily, however a quick update:

After having snapper rollbacked to my newest X11 snapshot, I am back to a Wayland snapshot. Installing/updating any application on X11 causes the tty and Could not start Display server on vt 7 error again, so here I am. Rollback would have made this all far too easy :crazy_face:

You can set the default displaymanager by using updates-alternatives:

update-alternatives --config default-displaymanager

Also the default xsession:

update-alternatives --config default-xsession.desktop

It seems @mrmazda was on the right track, booting directly to tty purposefully and removing ~/.cache allowed me to change SDDM to remove autologin, allowing me to choose which compositor I wanted.

However, installing/upgrading via zypper results in tty with sddm erroring at Could not start Display server on vt 7 again. This seems like a different issue, even if the two happened at the same time.

So for now, I am “reverted” to X11 to my satisfaction and will begin investigating my new issue here shortly. I think that’s all for this topic.

Thank you all who offered their advice and help, it was greatly appreciated!

for the record, since I had a similar problem and could not find a proper solution: uninstalling wayland x server worked around it for me. No fiddling with config files needed. hth

I ended up running into bigger problems which may or may not have been related. A fresh install on top of my normal install (keeping EFI Boot, Home, Swap partions) and importing my user fixed a lot so I’m happy.