KDE partition manager system files

Hi Folks,
First off, the app wants me to give root password twice before I can do anything. I see there is a bug report but no fix?
Second, this screen pops up every time.

I can’t find the file.

Thanks

You may have a reason, but why not using the system management tool native to openSUSE: YaST > System > Partitioner?

Standard OSS repo…

ich@laptopneu:~> zypper se -si util-linux

Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name               | Type  | Version    | Arch   | Repository
--+--------------------+-------+------------+--------+-----------
i | util-linux         | Paket | 2.39.3-4.2 | x86_64 | repo-oss
i | util-linux-lang    | Paket | 2.39.3-4.2 | noarch | repo-oss
i | util-linux-systemd | Paket | 2.39.3-4.3 | x86_64 | repo-oss

After installation you need to enter the “Tools” Menu-> filessystem support->rescan support

1 Like

Hello hcvv, I have tried to use yast partitioner but it always fails with error about system not mounted at / when I try to apply changes. Besides, KDE partitioner you just right click the partition and choose what you want to do. In Yast you have to keep clicking page after page to do the same things.

Hello hui,

The command indicates the packages are installed. Still getting the error screen. By the way, I got a different one when I plugged in a USB drive. It said I didn’t have dosfstools. So I did that same command and got them. Now I don’t get that particular error. Just the original one about swap support.

When starting yast partitioner, I get this error:

yast error

I checked the /tmp/lib… folder and it is empty.

When starting it how exactly? I do not see any errors on up to date KDE Tumbleweed and I most certainly do not get this funny icon (I get norma YaST icon as it should be).

Now this is on Leap 15.5, but I do not think that things will be very different on Tumbleweed:


And this is very different from what you show. Can you please explain very detailed what you do.

And also

Explain what you want to do. Remember: How To Ask Questions The Smart Way
We are no mind readers.

Insert usb drive for formatting. Open YAST. Click partitioner and enter root password. Get error above about command ‘usr…’. Continue. Click usb drive. Delete partition. Create new partition. Go through options to format as FAT. All done, click next and get this error:

usb final

Cannot continue after that. Have to close program and use KDE partition manager.

Am I doing something wrong? Or is my system screwed.

I see always a different sequence: Start YaST > pop-up asking for the root password > Yast main window > choose Partitioner > get pop-up asking me if I feel qualified > click Yes and then the window as shown above is opened.

I am not sure, but I get a feeling that your system is not up-to-date or incorrectly updated. Can you please show your partitions:

zypper lr -d

rick@rick-opensuse:~> zypper lr -d

| Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | U

RI | Service

rick@rick-opensuse:~> zypper lr -d

| Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service

–±---------------------------------±---------------------------------------±--------±----------±--------±---------±-------±----------------------------------------------------------------------------------±-------
1 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
2 | download.opensuse.org-oss | Main Repository (OSS) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/ |
3 | download.opensuse.org-tumbleweed | Main Update Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |
4 | hardware_razer | hardware:razer (openSUSE_Tumbleweed) | Yes | (r ) Yes | No | 99 | rpm-md | https://download.opensuse.org/repositories/hardware:/razer/openSUSE_Tumbleweed/ |
5 | openSUSE-20231202-0 | openSUSE-20231202-0 | No | ---- | ---- | 99 | rpm-md | hd:/?device=/dev/disk/by-id/usb-JetFlash_Transcend_8GB_07VO4HA4B8BHPHR0-0:0-part2 |
6 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | ---- | 99 | N/A | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
7 | repo-openh264 | Open H.264 Codec (openSUSE Tumbleweed) | Yes | (r ) Yes | Yes | 99 | rpm-md | Index of /openh264/openSUSE_Tumbleweed |
8 | repo-source | openSUSE-Tumbleweed-Source | No | ---- | ---- | 99 | N/A | http://download.opensuse.org/source/tumbleweed/repo/oss/ |
rick@rick-opensuse:~>

Please use preformatted text tags </> in the forum editor to post terminal output. It makes it easier to read as it preserves formatting…

That looks fine (but please note @hui 's remark).
Are you up-to-date. When did you last do a zypper dup ?

Installed repos, did update, did partitioner. Didn’t get lib error message but did get system not mounted at ‘/’. Tried multiple different file systems for format but no luck.

Does opensuse have a usb formatter?

Please always give exact information. We can not look over your shoulder:

  • What do you mean with “installed repos”?
  • Did you do zypper dup ?

So something changed with the actions above.

And it does not matter what the hardware of the mass-storage device is. Partitioning and/or creating file systems, etc. is all the same.

Let me start over.

After zypper dup and reboot in tty, I open Yast → Enter root password → open Partitioner → Answer YES → Get this error:

Error 1

Click Details to get this message:

yast error

Click OK → Continue → Get this screen:

Click sda fat partition → Delete → Next → Add → Primary → Next ->Data → Format ext 4 → Next → Next → Get this error:

usb final

Click OK → Exit Partitioner.

And then you show GUI screenshots. Some steps or explanation are certainly missing.

Like @arvidjaar I am confused.

Because you are talking about KDE from the beginning, we assumed that you are as a normal user logged in in KDE Plasma and then open de Main menu and there click the YaST icon to start YaST.

This seems not to be the case, but I have no idea what you do instead. As I said earlier “I open YaST” is not an exact description. We need a command, or whatever you do.

The text between the screen shots aren’t showing? They show the actions taken to get each screen shot.