KDE Panel is of the screensize


I’ve just installed the new opensuse 11.

My panel got somehow to the top of the screen and I wanted to move it downwards again.

I tried it via “drag and drop” but I’ve got this panel now spread out all over my screen!

Any idea how to get it back to normal size? left/right clicking doesn’t work.

I have a completely gray screen where only the mouse symbol is present which I can move.



Which version of KDE are you using? For KDE 4, right click on the panel and make sure widgets are unlocked (if they’re locked it’ll give you an option to unlock them, if they’re unlocked then it’ll give you the option to lock them). Then right click on the panel and choose Remove Panel. Then right click on your desktop and choose Add Panel. This will add a new panel for you. The most common widgets to put back on are Application Launcher, Pager, Task Manager, System Tray, Digital Clock, Device Notifier, etc.

Take Care,


Thank you Ian,

When right clicking, there is only one option for removing namely “remove this panel”

When chosen, nothing happens and nothing else can be done (even no more reaction on right clicking), and the screen remains gray with this panel still spread out from top to the bottom. So, I can’t click on the desktop but only on this panel.

I can log out, and then log in, and then rightclicking again results in the menue where “remove this panel” is present.

Can you think of anything else?

Try renaming your .kde4 folder.

Open dolphin by typing alt+f2 then typing dolphin and selecting dolphin. Then navigate to your home folder and click view>show hidden folders. There will be a .kde4 folder so just right click it and choose rename. Rename it to something like .kde4_old. Then log out and log back in (or just hit ctrl+alt+backspace twice in succession).

Take Care,


If you have many kde4 apps configured and don’t want to loose the settings,
then you can just rename (or remove) plasma config-files in ~/.kde4/share/config/ .
Their name starts with ‘plasma’. In KDE 4.3.0 they are called


If you didn’t configure any KDE 4 apps, you can do as ijbreakey suggested:
just rename (remove) ~/.kde4 foder.

Ah, yes that’s the file. I couldn’t think of it off the top of my head. But as the first post states he just installed openSUSE 11.1 so I figured he hadn’t done too much customization yet other than making his panel fullscreen.


If you have done some customization follow seld’s advice. Either one will work but his advice is more specific and will avoid losing any customization.

Take Care,