I realize the KDE Package repositories listed at KDE/Repositories - openSUSE are not officially supported by OS. But they are a complete mess AFAICS. I added the distribution release and stable sets to YAST, and enabled them, but attempting to update packages in these repositories leads to endless conflicts because of missing dependency updates. So I just disabled them and gave up.
But why should these repository be so bad. Evidently the maintainers don’t care that they add packages to them which have dependencies on other packages which are nowhere to be found within the set of repostories.
It is very disappointing to want to get the latest KDE updated for OS 11.1 and to be stymied by these poorly kept repositories.
I am running OS 11.1 and not OS 11.2. As you can see from the list above I have added all the KDE repositories from KDE/Repositories - openSUSE which are designated as ‘Distribution Release’ and ‘Stable’ as well as the stable Qt. I have no interest in the factory, unstable, and otherwise KDE repostories. Unless that page is wrong I can hadrly believe I have added the wrong repositories but I am willing to correct them to resolve my problems with KDE upgrades. I am running KDE4 under OS 11.1.
I go to Software Updates, and let it refresh the necessary repositories. I go to my Qt repository annd notice an update for libca2. I attempt to update it only to be met by the fact that the update is looking for libqt4-4.6.0-14.1.x86_64. But it is nowhere around. All sorts of other updates in the rest of the KDE repostories are looking for this updated package, but the dummies who created these repositories just “forgot” to put libqt4-4.6.0-14.1.x86_6 anywhere. This is the sort of thing of which my OP complained.
I did as you suggested. I disabled the appropriate repositories and put the Updates repo at 99. I then went to the KDE Core Stable repository and chose Update Unconditionally. I still received a huge swath of conflicts. Unfortunately the software update tool makes it impossible to copy the screen with the conflicts. I will give you the first one but there are plenty others:
kdegraphics4-4.1.3-4.6.x86_64 requires kdebase4-runtime < 4.1.60 but this requirement can not be provided.
There are tons of others like this. I just do not have the patience to figure out why these repositories are so out of sync with their dependencies.