kde/nvidia slow down with dual monitor configuration

I run opensuse 11.3/kde desktop.

  • updated to KDE:Factory
  • X11 repository (V1.9.3)
  • proprietary nvidia drivers (260.19.36)

Video card is a Quadro NVS 290. A dual head configuration using twinview is run.

The desktop becomes slow almost immediately (couple of seconds) after logging in (all applications). Turning off desktop effects does not make a difference as well as trying the various recipes on the internet regarding x.org conf-files.
The only action restoring responsiveness is to simply start nvidia-settings. Putting the following pseudo-action into a script-file and mapping it to a key allows to have a workable environment:

nvidia-settings -a PixmapCache=0 && nvidia-settings -a PixmapCache=1

It is very annoying having to press a key every minute or so. Instead of creating a cronjob I would like to solve this issue. This behavior has been consistent across kde/x-org/nvidia/kernel updates for many month now.

Any help appreciated.

Is this a 32 or 64 bit installation of openSUSE? Did you install the nVIDIA driver from the nVIDIA repository or did you install it the hard way? I have found using 64 bit openSUSE, installing the nVIDIA proprietary driver the hard way (260.19.36, same as you) and updating the kernel to 2.6.37 and this has worked very without any pauses of the system. There is some sort of issue going on with openSUSE 11.3 32 bit when using KDE as I understand it and a beta nVIDIA driver 270.29 is said to fix this, but it can only be installed the hard way and it is very beta in nature.

Thank You,

This 64 bit with the nvidia repository. I wonder what differences I could expected installing nvidia “the hard way”? Is this a matter of getting more recent versions of the driver?

Thanks, Stefan

This 64 bit with the nvidia repository. I wonder what differences I could expected installing nvidia “the hard way”? Is this a matter of getting more recent versions of the driver?

Thanks, Stefan
The simple answer is yes. Installing the nVIDIA driver the hard way allows the install of the very most recent driver. So, if the problem was the older driver, you can try the most recent and even a beta driver if you wanted. For instance, we know that at this moment, the nVIDIA beta driver is up to 270.30 and some have indicated it was fixing an issue with KDE and the 32 bit driver installation. I must also say, that if you intended to upgrade your kernel, outside of the normal security updates, then loading the nVIDIA driver the hard way is almost a requirement.

If you have nVIDIA hardware, not having a problem and sticking with the normal kernel releases, which for openSUSE 11.3 is 2.6.34.? something, then using the repository method is without a doubt the way to go. Every time a security update is pushed down the pike, the nVIDIA driver gets reloaded automatically with the new kernel. While you must reboot after the update, there is nothing else you need to do. So it is very simple way of life. If on the otherhand, you update your kernel, say up to stable kernel version, after that update, you must also then reload the nVIDIA driver. Now I have written script files that can do all of this for you, but it takes some effort to perform.

Now we look at your case. You have some issues and not sure what is going on or just what the fix might be. It is very likely hardware related, but just what is the issue? Is it video or memory or your hard disk or something else? Now defective hardware is not going to be fixed by a software update of any sort. If on the other hand, it is some sort of incompatibility, your basic fix is to load a more recent version of your drivers. Most drivers are included in the kernel while a few can be loaded externally, like your video driver. So, what action do you wish to take here?

Thank You,

Unfortunately, the problems persist with the Nvidia driver 270.30. Also dual-head is not the problem as a single-head configuration exposes the same problems. Over time, I noticed that the ‘nvidia-settings -a PixmapCache=0 && nvidia-settings -a PixmapCache=1’ fix did not work any more. However, switching to a virtual terminal (ctrl-alt-F1) and back reinstates full speed reliably. Seems that some state becomes stale somewhere and gets cleared by the switch. This is very annoying behavior and any help is appreciated.

Well I am sorry to hear about the problem still existing. Just today, I see that driver the nVIDIA proprietary 275.21 version has been released and so it might be worth while to give that version a try and see if it works any better for you.

Thank You,

I have the same problem which appears from time to time (since … OpenSUSE 11.1). Some random ‘magic’ actions with windows (e.g. resizing, switching between applications) or nvidia config speed up the desktop. I noticed, when window is streched to only one monitor (not both) the problem almost disappears.