KDE not starting up on boot

hey there, I shifted to openSUSE 11 & KDE 4.1 recently, while till yesterday everything was working fine. Now all of a sudden, on booting, I get a console login. The system does goto run level 5, though. after logging in, I’ve to issue a startx for KDE to start.

Now the here it gets weirder

  1. On issuing startx I get auto-logged in, even though I have auto-login disabled (I did have it enabled previously, afterwards I’ve disabled it)

  2. The DE to which I get booted into is random - sometimes its KDE4.1, sometimes its KDE 3.5.9, sometimes its Gnome, although I didn’t choose to install KDE 3.5.9 OR Gnome, prolly got isntalled because of some dependencies ? :-/ I have no idea.

  3. Even on the rare occasions that I do get a KDE4.1 bootup, I plasma crashes with a sigsev

I tried removing .kde and .kde4 directories in /home but makes no difference

Any suggestions on
(1) How to get the GUI without having to issue startx?
(2) Ensuring that KDE 4.1 is what starts up ?

Help would be highly appreciated.

Another thing, I cant seem to mount my P1i as a mass storage device, which 10.3 did effortlessly. Now when I plug it in, KDE daemon (under KDE 3.5.9) shows New media - unmounted har drive volume, and when I choose open in new window I get a message

org.freedesktop.hal.storage.mount-removable no ← (action, result)

But I can mount it manually. Anyway I can get it to automount?

Thanks!
Sathya

EDIT: got the automount fixed.

umm a little help please ?

1/ I’ve exactly same :slight_smile: I don’t know how to disable it (and i’m not interested in, so I never found this “bug”)

2/ When your are on Desktop, choose “Logout”. KDM will start. In “Session type” menu, choose “KDE4.1” (not default). Then Login.

3/ KDE4 is still under developpement, you won’t be able to use plasma without (sometimes) random crash. And disable the “Desktop effect” under KDE4, it’s not mature yet.

Spyhawk, thanks for the input
Unfortunately on choosing logout, I’m thrown back to console, so I cant get the screen for choosing session type.

Just topitch in, here’s a look at my /var/log/kdm.log

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.4.0.90
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux sathya 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686
Build Date: 07 June 2008  12:37:27AM

        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 22 11:02:30 2008
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module "ramdac" already built-in
Synaptics DeviceInit called
SynapticsCtrl called.
Synaptics DeviceOn called
Could not init font path element /usr/share/fonts/TTF/, removing from list!
Could not init font path element /usr/share/fonts/OTF, removing from list!
Driver not XRANDR 1.2 capable, ignoring DISPLAYMANAGER_RANDR_MODE_* settings
KCrash: Application 'kdmgreet' crashing...
Synaptics DeviceOff called

eems like KDE4.1 is starting, plasma doesn’t load, when I issue plasma & at terminal, plasma gets loaded with widgets, ie, with the second Application launch bar and all:
here’s a pic

http://www.imgx.org/pthumbs/large/10791/plasma.png](http://www.imgx.org/pfiles/download/10791/plasma.png)

PS: I have disabled desktop effects and Compiz-Fusion :slight_smile:

Hey there. Well good news is that I’ve fixed the kdm_greet crashing issue, while going through the startup logs in YaST(God bless it!!) I found this particular entry

 kdm_greet crashes with code 125 signal 0 

A quick Google search for “kdm code 125” gave me this page as 3rd result which mentions,

kdm was working perfectly until … kdm_greet crashes with code 125 signal 0 after debugging with gdb, I find that findfont from xfree called by qt was in
cause. Then I made a fc-cache and all worked perfectly
So I do a fc-cache in console, restart and BINGO! No more crashes!!
One problem still remaims - it’s booting into KDE 3.5.9 instead of KDE 4.1!
I had a look at /etc/X11R6/xinit/xinitrc.common which calls the startkde script
The startkde script loads KDE4.1 Besides there’s a separate starkde3 script.
So any pointers on how to get KDE 4.1 starting ?

Have you updated from 10.3 to 11.0 instead of a clean install? I would guess that there are a number of files that need to be updated. You might check /etc/SuSE-release and ‘uname -a’ to confirm that you are running 11.0, then ‘zypper up’ and then ‘zypper dup’. I haven’t figured a way to do that from yast yet.

@davidgurvich It was a fresh install, I wiped out all of my previous openSUSE partitions and installed with KDE 4 as the DE. Will try the zypper thing soon