KDE not showing my photo camera plugged with USB


I’ve got a strange issue. I used without problem my Olmypus camera with oS 11.2 and older but sinds 11.3 and the new KDE, nothing happens anymore when I plug my camera: nothing appears in the device notifier, nor in Dolphin. It did in the past, with oS 11.2 and KDE 4.3.x. But, in IceWM, with Dolphin and Digikam it does work (it appears like a USB stick). Not in KDE with the same applications.

What I wrote in the bug report:

Steps to Reproduce:
1.Plug your digital photo camera in a USB port
2.Optional: open Dolphin
Actual Results:
Nothing happens
If you try to import from Digikam it doesn’t work either (nothing appears)

Expected Results:
Device notifier should notify the camera or Dolphin should make the camera
appear in the Places panel.
In Digikam, with Import>Camera, you should be able to see the pictures.

If you open your session with IceWM and then Dolphin and that you plug the
camera, it’ll appear in the Places panel. It will be also possible to import
from Digikam.

If anyone has a clue for a workaround want it’s very anoying, I can’t use properly Digikam >:(

Thanks in advance for your help! :slight_smile:

I found that the Device Notifier in 11.3 needed configuring. Have you tried that?

Hye John, I tried that but there isn’t much to configure… I didn’t find anything that worked with changing the configuration.

I have an Olympus that 11.3/KDE 4.4.4 does not detect. Prior versions detected it fine.

Found that leaving the camera plugged in and rebooting will bring it up, but sometime requires several reboots :frowning:

My camera was mounting with group perms of lp. Adding myself to the lp group. logging out and back in fixed the problem.

That doesn’t work for me… I was already, in lp group but it doesn’t work.

Any other track?

I have the same issue here and so far here is what i think it caused it (sincei am a rather newbie in this bussines it’s just an ammateur oppinion).

In my case using dmesg |tail command after i plug in my camera (Olympus SP 500UZ) i got the following feedback:

1460.052033] usb 2-1: new full speed USB device using ohci_hcd and address 5
1460.261689] usb 2-1: New USB device found, idVendor=07b4, idProduct=0109
1460.261692] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
1460.261695] usb 2-1: Product: SP500UZ
1460.261696] usb 2-1: Manufacturer: OLYMPUS
1460.261698] usb 2-1: SerialNumber: 000J20284188
1460.264834] scsi11 : usb-storage 2-1:1.0

As you can notice it seems that UDEV didn’t create a node for the Camera memory. (By chance i had the camera plugged in during the setup :slight_smile: and it displayed it as a vfat drive. However after re-connecting camera / restarting OS) the camera isn’t mountable anymore.)

As i said my linux background is limited so i need your oppinion in how to “persuade” udev to assign a node for my camera when plugged in.
Here is what the Hardware info tool in Yast displays.


Also I am using OpenSUSE 11.3 64 bit with 2.6.34-12-desktop kernel

Now i just hope my post makes sense :slight_smile:

Thanks in advance,

Some digital cameras have a setting that can be applied, to make them appear as a mass storage device. Check your camera’s configuration menus to see if there is anything appropriate there that can be changed?

actually it doesn’t have such a menu…at least not in a static mode. My model displays a menu when i connect the usb cable and one is called PC. When i try to connect on windoze all i have to do is to select this menu, the drivers are automatically installed, the card is mounted and everything seems to be OK.I suspect that the camera goes to mass storage mode once i choose the PC menu since nothing else works in that state. I’ll keep searching. Until then maybe I will find a manual way to persuade UDEV make a node using the ID’s (and the other information) the OS is displaying (see my above entry).

Thanks for quick reply,


I found it!!! Apparently the PTP mode seems to work better than the USB one. Ofc following the advice from someone on the Romanian OpenSUSE community i installed the ptp daemon and I’ve searched some references on the internet until i stumbled upon this article Digital Camera Support for UN*X It seems that the PTP technology is used by Olympus for the Printer bridge and even if the camera menu might be misleading ( Easy/Custom Print) it works like a charm on PC Connection (when running Open SUSE ofc). Now i can only helps it will help someone else :slight_smile:

Thank you,