kde not automatic start on boot (Opensuse 11.3)

opensuse 11.3 (x64)
KDE 4.6

a week ago I doing update using “zypper up” . half way I stop it .
then today when I try ON it to continue the update , I found I unable to boot to kde desktop . a Konsole box show up . I try startkde but failed.

I decide try to continue the update using zypper up (after went through trouble to connect wireless with command line) .
after the update, I able to run kde using startkde (the konsole box still open) .
when I restart , it still show me the konsole box, not kde desktop.

xdm service is running

i tried chkconfig -l xdm

how to I solve this problem?

can you boot to IceWM?

Just a guess, but maybe worthwhile checking that /etc/sysconfig/displaymanager has the required entries


thanks. I now able to boot to kde desktop but unable to shutdown, restart or logoff

I have to use “shutdown -r now” to shutdown

I google around seems to be problem with kde 4.6

anyway to solve this?

Remove all repos except the defaults and run zypper dup again

problem solved after I did an update today rotfl!.