[KDE] No Networkmanager in systray

Hey,
I made a fresh net-install of tumbleweed. However I don’t see the networkmanager in systray (or at all), LAN works though.

How do I get nm in the tray?

LSPCI:


00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RX780/RX790 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RX780/RD790 PCI to PCI bridge (external gfx0 port A)
00:06.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD790 PCI to PCI bridge (PCI express gpp port C)
00:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RX780/RD790 PCI to PCI bridge (PCI express gpp port D)
00:12.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 Non-Raid-5 SATA
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI0)
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI1)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI2)
00:13.3 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI3)
00:13.4 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB (OHCI4)
00:13.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB600 USB Controller (EHCI)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB600 IDE
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB600 PCI to LPC Bridge
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV635 [Radeon HD 3650/3750/4570/4580]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV635 HDMI Audio [Radeon HD 3650/3730/3750]
02:00.0 SATA controller: JMicron Technology Corp. JMB363 SATA/IDE Controller (rev 03)
02:00.1 IDE interface: JMicron Technology Corp. JMB363 SATA/IDE Controller (rev 03)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 13)
04:06.0 Network controller: Ralink corp. RT2500 Wireless 802.11bg (rev 01)

It’s probably set to wicked instead of Networkmanager. Use YaST’s network module to set it to Networkmanager.

It seems to be a bug introduced with the change to QT5.7 in release “20161003”. The system tray icon is only visible when a connection is established. There does not even appear to be a “clickable” empty space where the icon should be.

P.S. It might be related to the Breeze build that also changed.

Thanks, that worked!

So I managed to setup my WLAN.

However now after login I’m always aked for root pwd:
“A systemsetting forbids to change network settings for all user, Please enter root pwd” (freely translated from german).

How can I disable this?

In the connection’s properties, general tab.

You mean the 2nd from the top: “All useres are allowed to connect…”?

Thats the first thing I enabled, but to no avail.

This is the prompt btw:

That’s the one, yes. Networkmanager by default saves connections per user. If you switch off the “All users” checkbox, you won’t be asked for the root password though. IMO you did hit a bug though, Networkmanager should ask for the root password when allowing other users to use the connection, not when they actually use it.

???
I don’t understand, do I have to set the checkbox or NOT?

Currently I have it set and from the wording of that setting I understand that this would allow everyone to use this connection WITHOUT root pwd…?

Ok, apparently one needs to UNTICK that option… very confusing…

The way it’s supposed to work: when changing the status from unchecked (default) to checked, the root password is asked and a system network connection is added. It should not ask the root password again, that would be a bug.