KDE Night Color Possible Bug (Looking for Help on How to Report This)

Good afternoon OpenSUSE Community,

**System Information:
**Operating System: openSUSE Leap 15.3
KDE Plasma Version: 5.18.6
KDE Frameworks Version: 5.76.0
Qt Version: 5.12.7
Kernel Version: 5.3.18-51-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-8665U CPU @ 1.90GHz
Memory: 15.3 GiB of RAM

**Possible Bug:
I’m not sure if this is specific to KDE or if this is related to my use of 15.3 OpenSUSE. I’m planning to load up a 15.2 LEAP and a TW virtual when I get a moment for my lab sandbox to make sure.

In my use, I really enjoy using a tint for my screen use as bright blue computer light tends to give me quick eyestrain (nerdy enough, I double up with Night Color on the box and blue-light reflective glasses :P)

Recently today, I had to **System Settings **and I accidentally clicked Display Configurations in my haste to resolve an issue (the issue was audio not visual… ). After clicking Display Configurations, the Night Color mode reverted to out of the box fresh install. Moving to Night Color configuration within Display Configurations, I saw that Activate Night Color was still checked but the Night Color was still not being activated. I clicked the box and then reactivated the option but the blue light intensive option stayed active while Night Color did not.

Long troubleshooting story short, I found the resolution was:

  1. Deactivate Night Color mode
  2. Click Apply
  3. Activate Night Color mode
  4. Click Apply
  5. Don’t go back into Display Configuration unless you want to repeat these steps :stuck_out_tongue:

What I see as the bug here is that I never deactivated the Night Color mode but going into** Display Configurations** for anything makes it automatically act as if it is deactivated. Also, checking found it was still active but just not being registered. Plus, the resolution was pretty much a system reminder - we are still using this but it’s not being active by deactivating, applying, and then reactivating and applying again.

I wanted to bring this to the community’s attention for help so that I can be educated on how best to go about having this submitted for review; either that be by the OpenSUSE team or KDE for further validation.

Thanks and I hope you are all doing well!


Did you setup your geographical location (latitude and longitude) in the Night Color Plasmoid?

  • I’ve never used any of the other settings possibilities – possibly the stored settings are being lost …

Be that as it may, the place to report KDE issues is – <https://bugs.kde.org/>.

  • But, it’s not as simple as that – IMHO, a good idea is, to first discuss the issue here and then, once the issue has been defined, report it to the KDE folks …

I’ve checked with this Leap 15.2 system – the settings seem to be stored OK …

Good evening dcurtisfra,

Thanks for your insight and reply.

To update, I did play around more with it last night trying to better figure out the night color option and found that after a few times playing around, it just stayed Blue Light all the time. Effectively, I really confused the system then lol

However, I did a simple shutdown to really make sure I cleared the system. Upon reboot, the Night Color option turned out without issue. I didn’t go back into the system settings to Night Color since turning on last night (after I really broke it lol) and today and Night Color is on all the time, now, without issue.

Also, I have the setting set to “Always On” without a Geo Location specific setting. My goal was there to have it always on since I prefer this style of lighting over bright blue light in electronics.

I hope that provides better insight and helps us lead more towards a solution for this bug. Recommendations are highly appreciated so that I can test out more ideas and share more experiences.

Thank you! :slight_smile:

Sad day to report:

Now Night Color is completely broken and I can’t find out why. It won’t register as being active or when it is deactivated.

No apply is allowed and it is always non-Night Color, now :frowning:

Many times “Ha!”
https://forums.opensuse.org/showthread.php/547808-Cannot-adjust-KDE-s-Night-ColorFor KDE applet for choosing colour profile is also available - install it additionally.