KDE Networkmanager uses "auto eth0" connection instead of my "home" connection

KDE - Opensuse 11.4.

After a boot the networkmanager always uses the auto eth0 connection instead of my “home” connection which uses a static ip. I can swhitch it back manually, but it frustrates me that after each boot, it used the auto eth0 connection again which uses DHCP instead of static ip.

Note: I have checked “connect automatically” for my home connection, but it seemes to be ignored…

I know that I could just drop the kde networkmanager and use ifup via yast, but that is just a workaround and not a solution to my problem. This problem was also in opensuse 11.3 and hasn’t been fixed…

You could try deleting /etc/NetworkManager/system-connections/“Auto eth0” (requires root), though I suspect that it will be recreated.

If the main point is to have a static IP, then the easiest (and usually the best) thing to do is:

Yast → Network Devices → Network Settings → Global Options

and there you can select “Traditional Method with ifup”.

Once you have made that selection, you can also set static IP address in Yast.

If you really must use NetworkManager, then you can edit “Auto eth0” if you are running gnome or LXDE. It is even possible to run the gnome NetworkManager applet in KDE (look for posts in the wireless forum), and set it there. Changing “Auto eth0” settings will require root, as will Yast.

Well, I don’t really get it. What’s the point of having a network manager if all the new connections you set up are never used. It always falls back on auto eth0. To me, this feels like bad functional design.

And why can we edit/delete auto eth0 in gnome but not in KDE?

Anyway thanks for the reply, I fixed it using the gnome network manager. But it still disappoints me that this hasn’t been fixed in KDE yet.

It is a deficiency of the KDE networkmanager applet (IMO), and I do hope that gets fixed.

The “ifup” way of doing things is to somewhere keep a bunch of different versions of “/etc/sysconfig/network/ifcfg-eth0”. Then, to switch settings, move the desired one into place and run (as root) “/etc/init.d/network”.

I have mostly used “ifup”. At present, I am using NetworkManager (with “Auto eth0”) experimentally. It seems to be more reliable with “ifup”. Specifically, when I reboot my router things still work fine when using “ifup”. But, when using NetworkManager, I have to disable networking and then re-enable networking in the network manager applet in order to get back to talking to the network. The router reboot shuts down its ethernet port, brings it up, runs diagnostics, shuts it down, brings it up. The two successive down/up moves seems to confuse NetworkManager, whereas with “ifup” the network interface is kept configured and the only effect is a couple of log messages about cable unplugged.

Why don’t You try plasmoid networkmanagement ? I think it can do just what You want it to.

Best regards,

Is that a newer version than came with 11.4? I am not seeing the options that you are showing. In particular, I do not see anything in the “Wired” connections setting, and if I attempt to create a wired connection, the “System connection” option is grayed out.

Yes it’s the version that comes with KDE 4.6.4 from the KDE stable repository. Once I get home I can tell You what is the exact version of the plasmoid.

Best regards,

Thanks. That is a change I will be looking forward to, when 12.1 is available.

This is the version from which the screenshot was taken :

rpm -qa plasmoid-networkmanagement

Best regards,

Thanks for the tip. I’ve been struggling with KDE’s Networkmanager since 11.1, over two laptops and a desktop. I also tried the new plasmoid-networkmanager, and had the same problems as with the KDE networkmanager. Except for the KDE networkmanager working briefly in 11.2 (I didn’t try it in 11.3 since I went straight from 11.2 to 11.4), the gnome applet is the only thing aside from ifup that works for me - I can use my WLAN, my wired DSL, and even my Nokia 3720 as a modem.