KDE login - wireless takes long time to start, other startup apps fail due to no connection

Hi SUSEians.

I’m using TW KDE Krypton (don’t know if Krypton matters), but I’ve got an annoying login issue.

Whenever I login or resume from suspend, it takes a long time for my wifi connection to connect. I’m dog-sitting this weekend and using someone else’s network, so it’s not just my LAN at home.

On login, it takes literally a minute or two for Network Manager to find the wifi “secret” and establish a connection. In the meantime, other apps and services are trying to start (Thunderbird, Updates, etc.) but fail because there’s no network connection. Even my weather applet bombs because it can’t fetch the current conditions.

Is there a way to either…

  • Speed up the wifi connection process, or…
  • Make other apps and services wait for the connection to establish before trying to launch?

This is only a problem since I switched to openSUSE. I’m using the same laptop I used to run Kubuntu on, and it connected immediately and I never got these kind of failures.

I know there’s a sort of competition or overlap between KDE’s Network Manager and the network module in YaST. Does anyone know what I should be looking for?

Thanks!

There should be no competition between network mechanisms ie wicked or NetworkManager. As it appears that you’re using the latter you should perhaps consider editing the connection to be a system-wide connection (available to all users) and set to connect automatically. The wifi secret will then be stored in a NM connection file, rather than using kwallet.

Sweet. Setting the network to be available to all users worked perfectly. THANK YOU.

(I didn’t explain myself well about YaST and NM… I should have just said that either Wicked or NM could be used.)

But anyway… your answer perfectly solved the problem in two or three clicks, so you get a :good: