KDE login screen: password required for "suspend"

Foreword: In fact i am running KDE in german, so the wording of the texts from the computer may be wrong - i hope, you understand what i mean.

On the KDE login screen (KDE4), you have the option to “suspend” the system (with my system, this is “suspend to disk”) - via Alt-S and a further detailled selection.
What bothers me is that i am asked for an “authorization by the system administrator” - in fact, the root password.

Note: The /etc/sysconfig-setting displaymanager_shutdown is “all”.


  • Is this “works as designed”?
    Note: if i select “turn off” or “reboot” instead of “suspend”, i am not asked for any authorization.
  • can i change this behaviour?
    I’d like to be able to suspend to disk without entering any password at that point.

openSUSE 11.1, just updated (September 19th 2009).
kde-kdm: v 4.1.3-10.3.7


I’m using KDE 4.3 right now so it might not be an option in 4.1.3, but try opening up Configure Desktop (Personal Settings) then click the advanced tab. Under system go to PolicyKit Authorization. Click the plus sign next to org.freedesktop. Click the plus sign next to hal and then the plus sign next to power management. Go to Suspend the system and make sure that it’s set to “yes” next to Active console.

Take Care,


Thanks, ijbreakey.

Unfortunately, my system is set up quite different: Althouhgh PolicyKit is installed (and even some additional package “PolicyKit-kde”), it does not show up where you explained to me - in that “System” section, i just see “Login Manager”, “Power Management” and “Samba”.

Just for curiosity: Did you install KDE 4.3 manually? I am a bit surprised that you have a higher version although i just updated my system.

Yes, I installed it manually. With openSUSE you can choose which one to use. We have KDE 4.1.3 which comes with a default 11.1 installation. There’s KDE 4.2 which can be upgraded to by following these instructions:

KDE4.2.* (How To Add) Guide. - openSUSE Forums

Then there’s KDE 4.3 which is still in the factory repositories, which means it’s good enough to try out, but shouldn’t be used for everyday activities unless you know what you’re doing.

I would suggest upgrading to at least KDE 4.2 first as there are many bugfixes, improvements, and new features implemented. Just follow that link’s instructions Step-By-Step (even going to the Repository Management link beforehand) and you should be good to go :wink: Perhaps your problem is fixed in KDE 4.2.

Take Care,


Oops … seeing it positive i could say: the problem disappeared.

Updating to KDE4.2 removed the “suspend” option from the kde login screen.
But the “PolicyKit” did not show up in the kde config / advanced / system, so i think that is a dead end - or i messed my system even before in a way no update will fix.

Never mind - i’m not even sure if i want to return to KDE 4.1 as 4.2 looks less “space consuming”, which is a real advantage for me as i have it on a netbook with a screen of only 1024*600 (!); sometimes this is hard to handle.

Thanks for your assistance, ijbreakey.