KDE login screen/ greeter theme

Hi, I notice that the login screen settings in ‘system Settings’ seem to have no effect and the YAST setting under sysconfig Editor /Desktop/Display managers/DISPLAYMANAGER_KDM_THEME is set to “SUSE” with no alternative. So I’m stuck with the vomit-coloured green login screen.

How to get the system to recognise the settings in ‘system Settings’ so I can import themes and make use of the alternates offered?

To switch to using the KDE login theme, you need to do the following:

  1. in YaST - System - /etc/sysconfig Editor

  2. Expand “Desktop” then Expand “Display manager”

  3. Make sure that the following config variables are set as follows:


DISPLAYMANAGER = kdm      
DISPLAYMANAGER_KDM_THEME = (empty) 
  1. Click OK.

Restart openSUSE and you should be using the KDE Login Theme.

Thank You,

Thanks James, at least I can log in without selecting any themes and set a suitable background now. I don’t seem to be able to select any of the themes on offer in the System Settings dialogue though. Typing the name of the theme into the YAST box seems a little long winded.

Look in the folder /usr/share/kde4/apps/kdm/themes where you will find SUSE that is set in the value **DISPLAYMANAGER_KDM_THEME = **by default as stated before. Any of the folder names that reside in the themes folder can be placed into this name in sysedit. I am not sure where they get downloaded from KDE.org

In my themes folder I see the names circles, ethais, horos, oxygen, oxygen-air and SUSE and could manually place any of the names into usage. I suppose you could manually place a new theme folder there as well.

Thank You,

Yes, I’d worked that out, my question was really how to enable the selection of themes in the KDE system settings dialogs rather than by typing into YAST. But at least I’ve got to the point that I don’t feel nauseous when I log on with that sickly green screen, thanks.