KDE Live CD 11.3 bootmenu graphics errors

I wanted to try the opensuse 11.3 KDE Live CD but I am stuck already in its boot menu. The boot graphics is shown first with a few graphics errors and then a text box appears in the upper left corner. If I hit a key a text boot menu shows up but also with graphics errors. And there is the message “graphics initialization error. Error setting up gfxboot.” Everything I do from here leads to even more graphics errors. I do have pictures of this but since I am new to this forum I failed to attach them to this message.

I have tried the CD on another computer and it works fine. I am running opensuse 11.2 on my computer and it works fine. The mainboard is a Gigabyte E7AUM with a NVidia 9400 chipset with integrated graphics (MCP7A) and, yes, it works fine.

Any ideas or suggestions?

So you don’t even get to choose anything at the menu?
Does anything happen if you press F3

I cannot choose anything. When I press a key (no matter which, i.e. incl. F3) I get a text console with something that could look like a boot menu incl. a prompt “boot:”. But again I cannot choose anything. I can wait and something happens which looks like it starts automatically. But since the screen is then completely messed up I cannot tell for sure. If I try to type something in, the standard answer is that it could not find the kernel. At least “memtest” seems to work. But again the screen is completely messed up with funny characters and I don’t dare to wait long until I reboot…

I will try to post some pictures. But I first have to figure out how I do that.

Upload Images in your Posts - HowTo

O.k. here we go:
This is the boot screen before I hit a key:
ImageBam - Fast, Free Image Hosting and Photo Sharing
These are two variants of how it looks like after I hit a key:
ImageBam - Fast, Free Image Hosting and Photo Sharing
ImageBam - Fast, Free Image Hosting and Photo Sharing

I forgot to take a picture of how it looks like if something is being started. But just imagine your screen full of random characters in random colors…

At this
ImageBam - Fast, Free Image Hosting and Photo Sharing

What if you type this at the prompt boot:


or perhaps equally as important this:

I tried that but for the first two I always get the message that the kernel was not found. mediacheck does something but I can’t tell what due to the messed up graphics.

You say it works on another PC but did you run the media check?

I did not try to run media check on another computer, if you mean that. Certainly I could do that.

@caf4926, I seem to recall seeing this issue a few years ago, with @oldcpu tearing his hair out with it. Don’t hold me to this, I think the conclusion was a problem communicating with the monitor that messed up the framebuffer, which causes the keystrokes to be mis-read. OP might try just hitting Enter at “boot:”, nothing else. And let the boot process continue; at the end it will try to load a graphics driver, switching control from the framebuffer to X.

And of course as you already suggested, check the media. Might also try the DVD. But the system may load if allowed to go all the way; can’t hurt anything if it doesn’t since it doesn’t touch the disk.

Yes I did know I had seen it before, but I couldn’t for the life of me remember the detail. And even though you mention it as above I’m not certain if it is the answer. This is similar but not quite:
NEW Users - Suse-11.2 Pre-installation – PLEASE READ

Can you let us know how things go please…

If you are sure that it won’t hurt to just let it run after hitting return, I might consider that. But usually I am not a big fan of not seeing what is going on on my computer. I certainly will do another backup before I try. BTW, which of the boot entries will be used?

I had a look at the link and recognized that I forgot to mention that I am talking about 64bit ;-). And please be aware that on these pictures at least the text boot menu is fine. In mine I do have errors and the message about gfxboot failing to initalize graphics.

I have not yet checked the media, but will do so in the evening (currently I am sitting in the office). I do not have much hope that this will help since I tried the install DVD which I put on a USB stick and ran into the same problems.

I just had a look at “syslinux.cfg”, isolinux.cfg" and “isolinux.msg” (isolinux.msg is the one I see on the text boot screen). As a naive user I would have expected them to agree on the boot menu entries, which they don’t. Might that at least explain the error messages when I tried to boot something, because I try to boot something which is in isolinux.msg but is named differently in isolinux.cfg?

If you can install 11.2
Do a fresh install of 11.2 then immediately remove the 11.2 repos - add the 11.3 repos and do zypper dup
More details here: SDB:System upgrade - openSUSE

Well, I could do that. But an upgrade to 11.3 is currently not too important and I think I would prefer to figure out what is wrong. My guess for the moment is that either my hardware (or BIOS) is bad or the boot loader has some bug. Certainly the boot loader must differ from the one shipped with the 11.2 live cd, since that one ran fine (may be I should re-check, I should have the cd somewhere).

Sorry for the late feedback. I had no time for further investigations yesterday.

I made a media check of my CD on another computer and it is fine. So it doesn’t seem to be the CD. And I confirmed my speculations about wrong boot menu entries. On the 64bit KDE live CD of opensuse 11.3 the file /boot/x86_64/loader/isolinux.cfg is wrong. I guess I should send this to bugzilla. Another thing I tried was to test the live CD of opensuse 11.2. I works nicely.

All these things for me quite strongly point to some issue with the boot loader of the 11.3. And as I said before I not only tried the live CD but also the DVD which I put on a USB stick following some steps I found in the opensuse forums. Both give me the same errors with graphics during boot time.

One thing I will try now is what happens if I just let the live CD boot the live system, i.e. I just let it run for some time…

O.k. so I started the live system and waited a little. YES! The graphics is back! Once the screen is good everything afterwards is also fine. I also tried my DVD from USB stick and it is also o.k. after a while. That means, the boot manager messes up the graphics setup…at least on my system. I am not sure when I will have time to digg into that, but I will certainly compare the 11.2 live cd to the 11.3 live cd. And may be somewhere I will find the cause.

Cheers and please tell me any ideas you have