KDE Launcher position changed

Usually, the launcher in KDE is at the bottom. I have not changed a thing with it. Today, when I clicked on it because I wanted to start YaST, the position is now way up at the top. See this:


You can see a bar up at the very top too. That was not there before. How do I get the launcher back to the bottom where it belongs? Even when I click on the klipper icon and the kmix icon, they too show up at the very top of the screen. Something must have made these changes but I don’t know what. I know I didn’t do it. I tried looking in the desktop settings and the plasma area’s settings but I can’t find it.

I’m running SuSE 11.4 64 bit, and KDE 4.6.00 (4.6.0) “release 6”

ok, I finally got it now.
This can be deleted by the moderator.

I still wonder what had happened, what could make the panel area do that? Anyway, I hope this does not happen again.

we’ll not delete it if that’s OK Bobby.

Did you have an extra panel added at the top?

oh, ok.

No, I did not have an extra panel added to the top. KDE must have been malfunctioning for some reason.

Why do you not delete the post? Is it for record keeping (such as proving stuff)?

We keep it because it may prove useful to someone else.

You see at the top right of your image, there is a New Activity tab. Those are there usually when a new panel has been added.
If you disable desktop effects they can be easier to see

Yes Carl defiantly she added a panel at top.

So, if I disable the desktop effects, then I can see what panel had been added by something and then I can get rid of it, right? Then I plan to re-enable the desktop effects.

ok, it happened again. Something added a panel or whatever and my desktop looked exactly like the screenshot in my first message. I did not add a new activity, nor another panel.
I tried disabling desktop effects and looked around but I saw nothing unusual so I re-enabled the effects. While the desktop effects were disabled, “New Activity” still showed in the plasma tab. Like I said, a new activity had not been added.

I don’t know, when I first installed SuSE 11.4, I did notice a 2nd updater and when I looked at what it was showing me, I saw that it was all for KDE and some of the updates it was showing me, I had already done using YaST. So I dismissed it and told it not to do any updates. I’ve been doing the system updates periodically using YaST’s online update so I didn’t think I needed a 2nd updater.
Maybe this new problem has something to do with that? :dont-know: :question:

I doubt that updater problem is related.

I occasionally see the updater tell me that there are updates, when I have just done an online update. When that last happened, I told the updater to go ahead. It churned for a little while, then showed that there was nothing to do. So I think that is just out-of-date cached information.

If you have not already done so, then right-click on your desktop and select “Lock Widgets”. That makes it a little harder to accidently mess things up. You will have to unlock them again if you really want to change something.

As I sometimes tell people - I keep widgets locked, because I am totally paranoid. I know that the moment I stop paying attention, some sneaky person will mess up my desktop. And I even know who that sneaky person is - it is me. That is to say, I make dumb mistakes from time to time, and locking widgets helps me reduce the risks of those dumb mistakes.

ok, I now have my widgets locked. I will make another post if that happens again.

If your /home is from a previous install, it’s possible some crud is causing issues. But I doubt it because I can reproduce what you have by adding a new panel.

Next time, see if you can action it or drag/move it

I can move it down by using Panel Options > Panel Settings and then I get something that allows me to resize the panel.

So it’s a panel?!

I guess so, I really can’t tell. It seems its the task manager bar, whatever the bottom bar thingy with all the launcher icons is called.

Ummm… Let me see if I can bring enlightenment…

I hope this makes sense


When I disabled the desktop effects, I did not see any panel bar across the top like that at all. I don’t see any panel like that on my desktop right now either.
How else can I tell if there’s a new activity open or panel that cannot be seen?

Not sure
I would unlock your widgets and see. Might be worth checking your other activities or try a new one. And I would also consider testing a new user login to see how it behaves.

I don’t have any activities. I never added any. I don’t even know what they are or what they do. It seems to have done it all by itself, like a strange bug or something.
The behavior seems to be intermittent. It could take days before it would act up again. If I did make a new user login to test, I would be able to delete/remove it completely, right?

If I did make a new user login to test, I would be able to delete/remove it completely, right?
Sure, no problem there.