KDE keyboard shortcuts stopped working

Yesterday, after a reboot, most of the KDE shortcuts stopped working, such as control + alt + L for locking the screen, or Alt + F2 for krunner or even the fn + F{7…12} for controlling audio ( I use an apple aluminum keyboard )

I usually find solutions for this kind of problem in a matter of minutes of googling, but this time I had no such luck…
I’ve already checked with xev to see if the keyboard was still correctly configured and I’ve also tried reconfiguring some of the shortcuts but it didn’t work.

Any ideas on where to look for the problem or any solutions?

I’m using openSUSE 12.1 with KDE 48 repositories (with all packages on the most recent version)

Thanks in advance,

So in KDE if you select Menu / Configure Desktop / Common Appearance and Behavior Group / Shortcuts and Gestures / Custom Shortcuts (On Left Column):

  1. Start the input actions daemon on login is checked


  1. KmenuEdit should have an X to its right

Take a look here and tell us what you find. Always consider doing a system restart after any KDE desktop update before deciding something does not work.

Thank You,

Every thing is configured like you said. And I did restart at least twice since this problem appeared.
I do remember “exploring” the Input Devices -> keyboard -> advanced section before noticing this problem, however I don’t think i changed anything.

So here is one thing you can try:

  1. Try a new user and if the new works OK, its a KDE user configuration problem, so proceed further down the list.

  2. You could rename the following krunner files using Dolphin and with hidden files shown, log out and log back in after done:


  1. You could empty your cache and temp folders /var/tmp/kdecache-user_name and /tmp/kde-user_name

  2. You could rebuild your local KDE config (in terminal):

kbuildsycoca4 --noincremental

Just a few things to try.

Thank You,

Tried all of those, only the first one worked. A new user does have all the shortcuts working just as expected.

I didn’t have most of those files you mentioned on step 2)

Anything other ideas?

You could just become the new user or rename the .kde4 folder in the usename with the problem then log out and back in. Any KDE settings will be reset if you do this, but there is a lot of stuff there and hard to know which part is bad. Krunner was said to a possible source of the problem and so you could try to find anything with this name and remove or rename it first.

Thank You,

Moving the ~/.kde4 folder worked, obviously at the cost of loosing all my configurations.
I suppose this is good enough but I would really prefer a less “disruptive” solution.
So which component of KDE is supposed to interpret the shortcuts anyway? Maybe plasma?

Its my understanding that Krunner runs the shortcuts. KRunner is the program launcher built into the KDE 4 Plasma desktop and shortcuts are just another way to launch a program.

Thank You,

That makes sense. However it’s only the shortcuts associated with launching programs that don’t work. For instance, Fn+F12 for “XF86AudioRaiseVolume” should raise the volume (maybe by passing a signal to kmix or something), but it is also completely ignored…
Is krunner also in charge of this type of thing?

As far as I can tell KRunner reads these values as shortcuts and uses the info to launch applications and pass info to other running programs.If you run the System Monitor, you should see KRunner in there.

Thank You,

Finally figured it out (I think…)

After deleting most of the files inside ~/.kde4/share/config the shortcuts started working again, but the keyboard model was set to Generic.
When I changed it to Apple Aluminum Keyboard (ANSI) they stopped working again. I’ve no idea why, since I’ve been using those settings for a few months now…
So all I had to do (thankfully) was set the keyboard model to MacBook/MacBook Pro (intl)

Thank you for your aid,

So it sounds like a strange problem related to the keyboard hardware selection. At least you found the suspect and it is something you could report as a bug for openSUSE I would think.

Thank You,