KDE graphics broken in OpenSuse 13.2

KDE graphics broken when open menus of native apps (dolphin, terminal, right button menu…)


Utils info:
OpenSuse 13.2, 8GB memory, i7 Intel


Drivers info:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
            Subsystem: COMPAL Electronics Inc Device 0065
            Flags: bus master, fast devsel, latency 0, IRQ 42
            Memory at c0000000 (64-bit, non-prefetchable) [size=4]
            Memory at b0000000 (64-bit, prefetchable) [size=256]
            I/O ports at 4000 [size=64]
            Expansion ROM at <unassigned> [disabled]
            Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
            Capabilities: [d0] Power Management version 2
            Capabilities: [a4] PCI Advanced Features
            Kernel driver in use: i915
            Kernel modules: i915

My related post here:

I was thinking it has solved. But today it happens again.[/size][/size][/size]

Can you confirm that you are now using UXA?

cat /var/log/Xorg.0.log | grep -ie uxa -ie sna
cat /var/log/Xorg.0.log | grep -ie uxa -ie sna
 92457.460] (**) intel(0): Option "AccelMethod" "uxa"
 92457.492] (II) UXA(0): Driver registered support for the following operations:

In “Configure Desktop” go to Display and Monitor, the Compositor tab.
What is set as the backend for rendering?

I can’t see this option

Configure Desktop > Desktop Effects > Advanced…

Thanks for steps. Image below…

Try setting the Compositing type from Xrender to OpenGL ( 2 or 3.1 ).

I did, then restarted the machine. And happens again.
Can be a problem in my video card?

Is there a way to restart the kde without restart the machine or close all programs?
Very boring restart all the time.

The quickest way is probably just to restart X with CTRL-ALT-Backspace (twice). You could also restart the display-manager service (as root) with

systemctl restart display-manager

It close all programs. Is like a quickly logout and login.
I just wanted to restart the scheme that this breaking (if that is possible). So I continue using KDE.

If you’re making changes to desktop effects settings, then you should be able to apply immediately. Then, when you next open Dolphin etc, the changes should be evident.

Changes were made a few days ago. And the graphical problem keeps happening.
So I think only change the settings on desktop effects not solved.

I was only making a general comment about the settings being applied. Have you tried changing the displayed KDE font?

I’ve tried to change it but also had no success.

I noticed an interesting thing now.
I am using the gnome while not solve the problem of kde.
But even the gnome, kde components of the present problem.
konsole, dolphin, spotify-kde and some others.

The i915 driver definitely has some problems. You could try a recent xf86-video-intel driver from freedesktop.org git.
Luckily there is a 1-click package available here: https://software.opensuse.org/ymp/home:pontostroy:X11/openSUSE_13.2/xf86-video-intel.ymp?base=openSUSE%3A13.2&query=xf86-video-intel
It is not considered stable but in my case a fresh driver solved the distortion issues.

I had the same problem. The problem is described here: https://github.com/git-cola/git-cola/issues/482
After upgrade to java 8 the problem disappeared.

I fail to see how this problem is remotely related to the issue discussed in this thread.

KDE graphics broken because QNativeImage can’t attach to shared memory segment. If user use applications running in Java7, after some time all applications based on QT look the same as on the screen presented on the page 1 in this thread.
Really problem has gone when i upgraded java from version 7 to 8.