KDE Font Sub Pixel Rendering

Trying to set up above;

Official Opensuse 13.1 repo for the infinality patch: improve subpixel font rendering in opensuse : LinuxActionShow

Add the namtrac repository with the URL above (or in your case using the tumbleweed directory instead of the 13.1 directory when adding) Then in the YaST software centre view this new namtrac repository and then click the button at the top which allows you to switch system packages to the versions in the namtrac:subpixel repository.
Make sure your KDE font anti-aliasing settings are set to “use system settings” for the infinality font rendering to work.
To configure infinality you can then install the “fontconfig-infinality” package from the standard OpenSUSE repository and then run “infinality-ctl setstyle” from a terminal as root. Personally, I prefer to change it to the “win7” setting over the Infinality default.
The Microsoft fonts are also useful with this setting, so I then also install the “webcore-fonts” and “webcore-fonts-vista” one-click-install packages from software.opensuse.org.

***But ***get dependency hell when trying to switch to packages within namtrac repo. I have YaST output in a text file;

Ubuntu Pastebin

Don’t believe everything you read on the internet. Some repos are much less “official” than others lol!.

I thought the only “official” repos were the “Current” + Tumbleweed. I have used the namtrac stuff successfully in the past when it was provided from an OBS home:user repo (unofficial of course) and it worked well. Seems things have regressed somewhat with officialdom.

Hmmm, total bunkem me thinks then. Thanks.

You might want to check out some recent threads about namtrac with the standard release, where not everyone succeeded (you may have already seen them). I think they used a different process to yours.

Droid Sans seems to do the trick.

consused wrote:
>
> have used the namtrac stuff successfully in the past when it was
> provided from an OBS home:user repo (unofficial of course) and it worked
> well. Seems things have regressed somewhat with officialdom.
>
>
Still a home repo
http://download.opensuse.org/repositories/home:/namtrac:/subpixel/openSUSE_13.1/


GNOME 3.10.1
openSUSE 13.1 (Bottle) (x86_64) 64-bit
Kernel Linux 3.11.6-4-desktop

Ah, that’s the one. I used it on Evergreen (11.4), a big improvement on Gnome there. Although I can’t exactly remember why not used here on 12.2 (issues at installation time probably?) and the community sub-pixel repo gives adequate results here. My 12.3 was upgraded from pre-release, the default fonts suitably configured were great (IIRC a windows font had been used, allegedly). On a later 12.3 clean install they regressed (someone had lost their nerve perhaps), and now the default 13.1 fonts need some attention.

Can someone please explain to me why the default fonts on 13.1 are so bad? I have a VM with vanilla 13.1 on it and they look just fine to me.

I didn’t say they were “so bad”. I would like them even better. Sub-pixel rendering should now be available even on openSUSE, lets assume it is working. For legal reasons it wasn’t, back whenever e.g. 11.4 time. It improves fonts especially on laptop LCD’s.

There is a further improvement IIRC that Windows has, called ClearType or some such. Clearer, sharper and darker (maybe). I think it is still protected legally and if so, openSUSE will not use it and one cannot complain about that (IMO). Some distros get close to it (dubiously?). When I tried the namtrac fonts on 11.4 they improved font rendering dramatically, and it was easy to see. The standard openSUSE rendering has definitely improved since then anyway. I don’t know how namtrac works. If I’m wrong about all this, I do hope someone will correct me.

Without a technical explanation or a good comparative photo, I doubt that anyone can explain it to you as it’s very subjective. The goal is to reduce eye strain. Many factors such as ambient light, type of screen, background colour, style of font and colour, type of rendering, eyesight quality, etc all play a part in how the fonts appear to you. :slight_smile:

Is there a way to report bugs to him?

Installing from Tumbleweed repo puts yast in dependency hell, while 13.1 works fine.

Repo list is standard for Tumbleweed, pointing to current. System packages, tumbleweed related, are all same vendor.