KDE - flood of systemd Journal entries - mostly related to information only

I’m occasionally plagued by KDE applications – especially Akonadi – flooding a user’s systemd Journal with informational entries.

The reason is, the default debug message level normally used only by developers to trace the application’s execution flow.

My solution to date is:

  • Install the package “kdebugsettings” and regularly execute the following:
 > rm ~/.config/QtProject/qtlogging.ini
 > kdebugsettings --disable-full-debug

Does anyone have another solution?
Does anyone know how to disable the KDE debug trace at system level without rebuilding every KDE package?

From Konsole open kdebugdialog5 and select “disable all debug output”.

1 Like


Only a small issue, “kdebugdialog5” doesn’t offer a means to disable all debug output from the Command Line – therefore, it’s not possible to use this method from a script.

  • On the other hand, it does seem to eliminate additional systemd Journal entries, in addition to those dealt with by “kdebugsettings”but, a new Journal entry appeared …


Jun 05 11:04:40 krunner[6408]: Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
Jun 05 11:04:40 dbus-daemon[4490]: [session uid=1000 pid=4490] Activating via systemd: service name='org.kde.runners.baloo' unit='plasma-baloorunner.service' requested by ':1.107' (uid=1000 pid=6408 comm="/usr/bin/krunner ")
Jun 05 11:04:40 systemd[4468]: Starting KRunner provider for baloo file indexer...
Jun 05 11:04:40 dbus-daemon[4490]: [session uid=1000 pid=4490] Successfully activated service 'org.kde.runners.baloo'
Jun 05 11:04:40 systemd[4468]: Started KRunner provider for baloo file indexer.
Jun 05 11:04:41 systemd[4468]: Started Konsole - Terminal.


Jun 05 11:14:52 krunner[6408]: QCommandLineParser: argument list cannot be empty, it should contain at least the executable name
Jun 05 11:14:56 systemd[4468]: Started Konsole - Terminal.

Dang, You can change MaxLevelStore in /etc/systemd/journald.conf? Also check /etc/xdg/kdebugrc.


The system Journal configuration parameter “MaxLevelStore” may almost be what is needed but, it’ll change everything – not only the KDE Plasma messages – I’ll take a look at it later.

I have the default ‘/etc/xdg/kdebugrc’ – everything is disabled by default.

  • And, Akonadi and, most of the KDE Plasma PIM items aren’t mentioned – apart from KOrganizer …

For the moment, I’ve removed ‘~/.config/kdebugrc’ and, everything else with “debug” in the name in ‘~/.config/’ and, have a manageable amount of user Journal entries.

1 Like