KDE: fix fonts in applications using KDE Development Platform 4.14 (e.g. okular)


I am running a fresh install of openSUSE Leap 42.2 with the KDE desktop, i.e.
KDE Plasma version: 5.8.3
KDE Frameworks version: 5.26.0
Qt version: 5.6.1

Some KDE applications (e.g. okular, mozilla-kde4-integration, krename, etc.) still use
KDE Development Platform 4.14.25. The GUI of these applications is drawn using a different font (some condensed bold font) than the GUI of those which use the new KDE Frameworks 5 (Noto Sans 10). See the two images below for a comparison (okular vs dragonplayer).



The default font in both System Settings / Fonts and Qt 4 Settings is set to Noto Sans 10.

Do you know how to change the font used by KDE Development Platform 4.14 applications so that Noto Sans 10 is used everywhere?

(Note the same difference does not exist e.g. in a default install of KDE 5 on Debian Testing (stretch), so the font can definitely be changed somehow.)

Thank you very much in advance!

My apologies, having taken a closer look, the above font differences DO exist under Debian Testing, too, but they are somewhat more difficult to see due to the similarity of the default fonts.

I have the same problem and asked the same question here. No answer so far.

Sorry, I haven’t noticed your thread. I have tried to get an answer in the KDE forum, too, in vain.
See: https://forum.kde.org/viewtopic.php?f=17&t=138691&sid=2609c5d8577c86027aef5f32e56edd37

I suspect that KDE4 apps might load their font settings from somewhere else (some legacy Plasma 4 config file?) than plain Qt4 apps configured by qtconfig. Do you have any idea on the font being used? We could then do a text search on the font name to find the corresponding config file… Unfortunately, I have no better idea :frowning:

As you wrote, it’s some condensed bold font, but I have no idea which one.

I think you found the answer :slight_smile:

Inspired by your suggestion I installed kdebase4-workspace-addons package which provides /usr/bin/systemsettings. It does not conflict with its counterpart from KDE5, because in kde5 the executable is called systemsettings5. Anyway, I executed this newly installed systemsettings and it miraculously synchronized setting for KDE4 apps with those from KDE5.

Finally, that solved the problem for me, too. rotfl! Thanks very much! Note, however, that the synchronization was not miraculous in my case (I had to set the font manually).

Yes, I encountered the same problem. in my case, puddletag looked awful. I did find another solution which seems to be THE way KDE wants us to go: There is a “Qt4 Settings” entry under “Dienstprogramme” (sorry, don’t know the exact wording openSUSE uses in English) in the application starter (I have Tumbleweed). This app lets us change the font for Qt4 programs nicely.

Thanks for this thread. Without it, I wouldn’t have looked into “Qt4 Settings”. :slight_smile: