KDE Factory dependencies problem

Hi,

recently when updating from

http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_Factory/

I’m getting the following dependency problems:

YaST2 conflicts list - generated 2009-12-02 09:58:28

nothing provides libical0 >= 0.44 needed by kdepimlibs4-4.3.3-117.8.i586

] do not install kdepimlibs4-4.3.3-117.8.i586

] break kdepimlibs4 by ignoring some of its dependencies

nothing provides libidn.so.11(LIBIDN_1.0) needed by
kopete-4.3.3-109.7.i586

] do not install kopete-4.3.3-109.7.i586

] break kopete by ignoring some of its dependencies

nothing provides libical0 >= 0.44 needed by
libkdepimlibs4-4.3.3-117.8.i586

] do not install libkdepimlibs4-4.3.3-117.8.i586

] break libkdepimlibs4 by ignoring some of its dependencies

My system is running on opensuse 11.2. And yes, I do want to run Factory
KDE 4.3.3 on opensuse 11.2, and I think I know what I’m doing.

I find the libidn dependency particularly weird, because it does not
give a normal version number. Does anybody know what I’m missing, or
whether this will be fixed eventually in the repo?

Thanks,
Jörg

Hope, this would help.

Howto: Upgrade KDE4.3.1 to KDE4.3.3 in openSUSE 11.2 - openSUSE Forums

Hi, thanks for the link. The article mentions two repositories:

http://download.opensuse.org/repositories/KDE:/43/openSUSE_11.2/
http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.2_KDE_43/

For the first one, opensuse’s wiki page on KDE repositories says
<http://en.opensuse.org/KDE/Repositories#KDE_4_Core_Packages_2>:

“KDE 4.3.x packages are extraordinarily made available in these
repos because of Factory containing KDE 4.3.1”

To me this sounds a bit like this repo might get dropped soon. But maybe
the wiki page isn’t up to date on novell’s / opensuse’s actual plans.

Does anybody know whether
http://download.opensuse.org/repositories/KDE:/43/openSUSE_11.2/ will be
available and updated for some time?

Thanks,
Jörg

On 12/02/2009 10:36 AM, mmarif4u wrote:
> Hope, this would help.
>
> ‘Howto: Upgrade KDE4.3.1 to KDE4.3.3 in openSUSE 11.2 - openSUSE
> Forums’ (http://tinyurl.com/yjvrprq)
>
>
>

Move to the …43… repos. They contain KDE4 4.3.4
Simply add the repo(s if you want Community and Playground as well), enter the software installer, select the repo view, tick repo, click “Switch system packages…”, Done.

To the OP: Are you aware that since the release of 11.2, the Factory
repos are for pre-alpha 11.3? As such, they are not guaranteed to be
consistent. If you have them enabled, your system may become very
unstable.