KDE - Epson ET-3850 scanner driver not working

ET-3850 Series
Scanner Driver Linux Epson Scan 2 All languages
Click [download]


click [Accept]

epsonscan2_e.pdf 416.91 KB download → save as

[ rpm ]
CentOS(Red Hat Enterprise Linux)
64bit(x86_64) Click [Download]

epsonscan2-bundle- [click on file] open file

Drag folder to downloads and open.

open superuser terminal

zypper install epsonscan2-


Start →
Yast Scanner, Scanlite, Epson Scan

run scanlite, no scanner found
run epson, no scanner found

super user

zypper install free-plugin-

Repeat above, no effect.

sh install.sh

No effect. Note, Second is an optional install. (?)

Need help…

Are you connecting your scanner via USB or network?

A USB cable to the desktop computer.

For internet, I use direct connect Ethernet, no wireless available.

Need sleep…

  1. Is the backend listed in /etc/sane.d/dll.conf?
grep -i ep | etc/sane.d/dll.conf
  1. Check if the scanner is enumerated with
scanimage -L
  1. Also, is the user a member of the ‘lp’ group for USB connected scanners?

  2. Does the included ‘epsonscan2’ application find and work with the scanner device?

As I am working, I won’t be able to answer the rest for a few days.

Does the included ‘epsonscan2’ application find and work with the scanner device?

I wasn’t clear. I tried:

skanlite: no scanner present
epsonscan2: no scanner present
yast_scanner: unknown

I’ll try uninstalling both the core file and the optional file. Delete all. Then install a new downloaded core file (driver) and install it.

Note, my older printer had no problems with scanner software,

For skanlite and yast-scanner: Both are frontends for sane.
That’s why @deano_ferrari recommended you to check the content of /etc/sane.d/dll.conf

As I have sane installed myself I checked it and there are four relevant configurations for epson:

What you would have to do for your scanner to be recognized is uncomment (erase the ‘#’) in front of the needed configuration for your printer and save the file. If the default configuration for your printer is not working you can edit the configuration file (which usually has a description) as well.

I wanted to check which backend out of this four is needed for an et-3850 and found that it’s not listed here: SANE: Supported Devices
So, you could try a backend of a related epson product.

And for the proprietary software: Could you start it from the terminal with epsonscan2 and see if there are any errors or hints shown in the terminal when you try to connect to the scanner?

From yast–>software, I uninstalled all epson files.

installed and setup printer driver
installed core scanner driver

Started epson2 scanner.
Clicked on scanner select.

Note, I deleted 8 color photos from the desktop/camera and couldn’t recover them.

Setup paper in scanner
start–> epson2 scanner
configuration: grey scale

After several tries with both scanlite and epsonscan2 at 600dpi, I managed to get a good scan. Then, proceeded to scan the rest of the photos. They are good enough to use a reference to take new photos with my good camera or send them as they are.

Thanks to all. :smiley:

Next time, I’ll need to get specific about what settings in epsonscan2 I need to get better scans of the b/w printouts.

Nice that it worked and thanks for the reply.

Just out of interest and because I am not 100% certain from your description: Did it work now with epsonscan2 and skanlite or just with one of them? As from how I understand your description you used the epson2 sane backend for skanlite, right?

EpsonScan2 worked acceptable for 8 scanned pages. Defaults–> 600dpi, print → grayscale settings

Scanlite was not working well, the image was distorted in some way. The black and white range was too small. The image was missing large areas. I used 300, 600, and 1200 dpi and I still got a distorted scan. I may have done the scanlite settings wrong. I’ll try it again and see if I get the same problem again. As usual, I’ll show all the steps.

Note, epson scan utilities is next. If I succeed, i’ll post here. Else, I’ll close this topic and make a new one

I scanned a image at 600dpi on epsonscan2 and 600dpi on scanlite. The resolution on scanlite was very degraded by a visible amount. Either, I need to change scanlite settings or there is a bug in scanlite.