KDE Dolphin - Git Managed Folders causing entire desktop to lag

I have no idea why, but every time I open a folder in Dolphin that’s being managed by Git, the system seems to run git to check every file in the folder one by one, causing Dolphin to lag for several minutes every time I change folders. It only happens in Git managed folders, so I’m assuming it’s related to the Git integration, but I can’t seem to find a way to turn it off, and considering I’m a professional web programmer, this is kind of interfering with my work. Does anyone know what the heck is going on and/or how I can turn this off?

No problem on my side but I don’t have any git integration setup with dolphin and I don’t think it’s installed by default on Tumbleweed, I assume you’re referring to this ?

If yes check for a package named dolphin-plugins ( zypper info dolphin-plugins ), if it’s installed you can try to remove it.

Additionally you could try running dolphin from the terminal to see if something is logged while using it when the problem occur.

It’s not dolphin-plugins, as I actually removed it when I thought it might be the cause. It’s currently uninstalled.

If you have flatpak installed you could try installing the flatpak version of Dolphin as there is a good chance that it will work so you will at least have a working file manager in the meantime.

If you say that the problem is tied to git folder specifically could it be related to the integrated terminal in dolphin? Maybe you have configured something here like changing the default shell to fish for example?

Are the git folders stored on local or do you access them trough ssh or ftp for example, if yes it could be part of the issue, another thing worth trying is to disable file indexation from system settings.

But what you should do is to gather more information, before opening a git folder open your system monitor to see what process consume all of your resources, open dolphin from the terminal with dolphin so you can expect some logs to show up and at last try to see if something relevant show up in system log.

The integrated terminal is running Bash; I can see the bash process under Dolphin in the system monitor. And when the lag happens, Dolphin clearly spawns a Git instance, one file/directory at a time until it’s checked all of them. They’re all on local hard drives. And if you mean Search Indexing, I disabled it a long time ago (it’s too resource intensive). And it doesn’t consume all of my resources; the entire system isn’t lagging, it’s just Dolphin.

Tested it multiple time on my side but it doesn’t seem that dolphin spawn any git process at all even while navigating inside folders where git is in use … My guess would be that your problem started after installing dolphin-plugins and one of it’s dependencies is still installed and keep the problem alive, but it is just a wild assumption…

The only thing left to try is to launch dolphin as vanilla as possible, no additional services ( context menu … ) enabled, terminal hidden on start to prevent the bash process to spawn and trying to retrieve logs …

Searching for your problem the best similar issue I was able to find was this one 473898 – Dolphin not usable - Git process at startup , it’s maybe worth trying to seek help on KDE dedicated forum or/and open an issue on the KDE bug tracker… I’m sorry that I can’t help more …

Just a thought. You could examine the output of lsof before and after you entered a git repo.

lsof -p `pidof dolphin` > /tmp/before_enter_git_repo

go to a git repo in dolphin

lsof -p `pidof dolphin` > /tmp/after_enter_git_repo

examine with some kind of diff program. I like kompare (kde) for smaller compares.

kompare /tmp/before_enter_git_repo /tmp/after_enter_git_repo