KDE does not start after upgrade

Please, help. I can’t create a new topic for my problem. I am writing here. Update from 15.4 to 15.5, everything was done as usual. As a result, my KDE graphical environment does not start automatically after the upgrade. All that appears is the console. The “startx” command gives some errors, the “plasmashell” also gives errors. I don’t know much about Linux, please help me. Thank you!
P.S. Never had problems updating OpenSUSE, last update 15.5 - problems.

I created a new post for you.

You probably tried to start a topic from the main page. You have to go first to a category (in this case Install/Boot/Login) and there one can normally start topics.

Welcome to the openSUSE forums.

That may be as usual to you, but there may be many people that usually do things different. Please never assume that the things you do and/or the way you do them are the only, or even the most usual, way do do it.

So please explain which method to upgrade from Leap 15.4 to 15.5 you used.

On the command line, is the Internet working?

You can test using:

> ping -c3 forums.opensuse.org
PING forums.opensuse.org ( 56(84) bytes of data.
64 bytes from proxy-nue.opensuse.org ( icmp_seq=1 ttl=55 time=18.3 ms
64 bytes from proxy-nue.opensuse.org ( icmp_seq=2 ttl=55 time=21.4 ms
64 bytes from proxy-nue.opensuse.org ( icmp_seq=3 ttl=55 time=20.0 ms

If so, can you do a “sudo journalctl -b | susepast”. That should upload your boot log to sustepaste, the command should return a link.

Please check if there is nothing you do not want to share in that paste and if so, please share the link here so others can have a look.

Typing error!

That should be

sudo journalctl -b | susepaste

mind the e at the end!

1 Like

Hi United76,

I’ve had such issues a couple of times after upgrading. It shouldn’t be a reason for panic. :wink:

Just a wild guess:
Do you have a nvidia graphic card? (Not sure about others.) After the upgrade they may not be working with the new kernel. It may be just enough to (re-) install the drivers.
For now, I have just one advice: If you are not so familiar with Linux, have you got used to YaST, though? The SUSE setup tool?
It’s available as CLI version. As root just type yast. Or as user: sudo yast Everything you could do to in the graphic version you can do in the CLI version. If you have used YaST before, this will be some comfort to you.
Nevertheless, after reading your susepaste others will able to give more precise advice. There will be advice to use the command line, which you should follow.

I used update from 15.5 disk. Booting from this disk and further - updating through the standard graphical menu. Not clear install, only update.

Yes. Old Geforce GTX 550Ti.

Yes, I have always used Yast when installing/updating apps.

Maybe you are right - the drivers are not compatible with the new kernel.

After your last comment the problem seems clear. The guidelines regarding 3rd party repositories whilst doing an offline upgrade seems not to be followed by you.

  • you used the image on a DVD/pendrive for upgrade
  • these offline medias doesn’t contain the NVIDIA repo
  • the NVIDIA repo gets disabled whilst the offline upgrade
  • additionally the disabled NVIDIA repo still points to Leap 15.4 instead of Leap 15.5

So you don’t have a NVIDIA driver installed that matches Leap 15.5


  • if you can enter a command line, login as root
  • add the Leap 15.5 NVIDIA repo:
zypper addrepo --refresh 'https://download.nvidia.com/opensuse/leap/15.5' NVIDIA

Install the drivers for your GTX 550Ti:

zypper in x11-video-nvidiaG04 nvidia-glG04


Another way that MAY work is: restart from the DVD/pendrive, use update, and adjust the NVIDIA repo URL as described in the above link. Finish the upgrade, cross fingers…reboot

Thank you, I’ll try.

I tried. The result is the same. Here is a screenshot from the monitor screen. It was the same before installing the graphics drivers.

I’m sorry, the quality may be bad.

Hmm, startx shouldn’t be required. If the driver has been installed correctly normally you should get into the graphic login screen automatically after reboot. Did you reboot?

On the other hand, you tried to do this as user, right? I think startx requires root permissions. To be safe on that behalf you may try again as root.

After all, nobody knows what you have done. Next time, please copy / paste everything you are doing on CLI here from first command till the last prompt.

For trouble shooting, we should start with:

zypper lr -d
zypper se -s g04
inxi -bCG

How if he can not reach graphical target? :open_mouth:

Yes, well…
In smartass mode I might reply “by using ssh into that machine from another computer’s konsole”. :grin:
But reasonably, I was rather referring to the screenshot which didn’t show what was told. The OP said he “tried” but then just showed the result. (Or am I missing something?)
@United76 So, rather than copy/past please use the appropriate tool available to you. :wink:
However, please show what you have done, completely.

@United76 you might want to switch to root user and run systemctl isolate graphical.target && exit and maybe the Xorg.0.log as well via cat ~/.local/share/xorg/Xorg.0.log | susepaste

I did everything as you advised. Photo result. Still, something is probably missing. Perhaps some drivers or packages.

Yes, KDE must be loaded automatically. But…it doesn’t happen.
Of course.

Unfortunately you have cut off the output from the “zypper lr -d” command at top. So it is not possible to see the NVIDIA repos. But the output from “zypper se -s g04” shows that you have a wild mix of Leap 15.4/15.5 packages for NVIDIA installed…
So please repeat “zypper lr -d” and show output.

After you have shown the repos, we can remove the old NVIDIA repo for Leap 15.4 and make sure that we have the correct one for Leap 15.5.

After that, the easiest way would be to remove all nvidia-* and all x11-video-nvidia* packages.

After that we can do a clean install from Leap 15.5 NVIDIA repo via:

zypper in x11-video-nvidiaG04 nvidia-glG04 nvidia-gfxG04-kmp-default


Thank you. I’ll try to do so.