KDE didn't work well (fresh reinstall)

I reinstall my OS because I had some issues with graphic driver (I have two graphic cards Intel/Nvidia) installing.

I install OS usually with nomodeset option but after I remove this option for standard boot for avoid issues about screen recognition and very low resolution caused (I already tried this issue).

When I go to my desktop after fresh install, now I see that the KDE bottom standard toolbar didn’t exist and I cannot restore it.

Why? Logs are clean about potential errors or warnings… And so far I don’t touch or install anything also after the install… What I could do for fix this issue?

is that a desktop or a laptop
if its’ a newish laptoop use bumblebee see this

if it’s a desktop go in bios and set the nvidia card as the preferred card you can ask google about it
then install the propitiatory nvidia driver see this

Thank you for your reply. I have a laptop (four year aged). I don’t wrote this topic for driver issue, but for KDE issue. First of all I’d fix KDE before try to install other things, for having better control. About driver installing I already know those guides that you kindly give me.

kde is fine, plasma 5 has issues with the nouveau and intel drivers which cause system freezes, the fix for your kde problem is to install the appropriate driver
4 yo means a 2013 made laptop that may or may not be optimus check with the manufacturers website (it probobly is optimus)
an optimus is a hybrid intel+nvidia setup that is primarily used to conserve power for simple things the intel chip is used for more intensive graphic operations the nvidia card takes over
if your laptop is optimus install bumblebee
if it’s not optimus go in bios and set the nvidia card as the preferred card and install the nvidia driver

the fact that plasma 5 (kde split in 3 separate projects the plasma 5 desktop, the kde 5 framework libraries and kde 5 applications)
does not work well with nouveau on nvidia chips is in the release notes
there is an open bug by the nouveau developers over at freedesktop

the only fix is to install the appropriate driver or do not use plasma 5 as the desktop (you can use it if you replace kwin5 with openbox)

Thank you again! Now your reply is much clear for me.

My laptop is optimus. Unfortunately I cannot set anything on BIOS.

Bumblebee, Nvidia Prime or Nvidia Standard drivers historically in this laptop never work with every distro I used (Ubuntu, Mint, Debian) and in these years I became very specialized about following dozens of guides, X-server panics and system recoveries. I usually keep nouveau driver for avoid nightmare installations and it usually worked well… Instead now I’m forced to find another resolution. I would use OpenSUSE and I would use KDE.

I’m trying to be as clear as possible
if your laptop is optimus it needs bumblebee to work
this is not an opensuse issue, all distributions using kde need bunblebee to work
see this wiki for help
I don’t have an optimus machine but the wiki is easy to follow
maybe a user who’s installed bumblebee can be of more help

Hello i have a laptop with intel 2gen HD3000, and the bug/glitch/error is not external graphics cards is the it-self dedicated card and the solution that i find was this

  1. Go /etc/X11/xorg.conf.d/

  2. Create 20-intel.conf

  3. Put:

    Section “Device”
    Identifier “Intel”
    Driver “modesetting”
    Option “AccelMethod” “glamor”
    Option “Backlight” “intel_backlight”


i dont know why the ppl of kde fix a bug to enter to other, because in the 5.8 early versions, this error not exist and the 5.7 neither have this error, i am using leap 42.2 KDE 5.8.x, other solution i try and work too is change opengl 2.x v to opengl 3.xv

I find the source of issue. It isnt VGA driver or VGA misconfiguration correlated but I notice that something badly supports HDMI port (OS? X? KDE? Kscreen? Motherboard issue?). I haven’t a 2nd screen connected, but the system believe that a 2nd immaginative display exist and it behaves as there is (for this reason logs are clean about errors or warnings). I fix this issue resetting the screen options whenever the issue appears. Maybe could be a much pratical and ultimately resolution. I’m searching it now.