KDE Device notifier take over iPad as MTP device and failed.

Hi,

I was about to jailbreak my iPad with iOS 6 under openSUSE, but unluckily, KDE took over my iPad the time it plugged in.

It was recognized as a camera (success) and a MTP device (failed).

So, is it possible to unleash my iPad from KDE (seems it was mounted, but the udisk2 changed its mount point, it was no longer mounted at /media, I want to umount it)?

And how can I resolve these errors in journalctl ?


Feb 05 21:33:13 linux-sclt.site kernel: usb 2-2: new high-speed USB device number 8 using ehci_hcd
Feb 05 21:33:13 linux-sclt.site kernel: usb 2-2: New USB device found, idVendor=05ac, idProduct=129f
Feb 05 21:33:13 linux-sclt.site kernel: usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Feb 05 21:33:13 linux-sclt.site kernel: usb 2-2: Product: iPad
Feb 05 21:33:13 linux-sclt.site kernel: usb 2-2: Manufacturer: Apple Inc.
Feb 05 21:33:13 linux-sclt.site kernel: usb 2-2: SerialNumber: 0f92eddeae47a1b5e8f53e082c510a31bfa1ef33
Feb 05 21:33:13 linux-sclt.site mtp-probe[9829]: checking bus 2, device 8: "/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2"
Feb 05 21:33:13 linux-sclt.site mtp-probe[9829]: bus: 2, device: 8 was not an MTP device
Feb 05 21:33:22 linux-sclt.site su[9682]: pam_unix(su:session): session closed for user root
Feb 05 21:33:35 linux-sclt.site su[9876]: (to root) marguerite on /dev/pts/1
Feb 05 21:33:35 linux-sclt.site su[9876]: pam_unix(su:session): session opened for user root by (uid=1000)
Feb 05 21:34:14 linux-sclt.site upowerd[1858]: usbmuxd_connect: Error: Connection to usbmuxd failed: Connection refused
Feb 05 21:34:56 linux-sclt.site su[9876]: pam_unix(su:session): session closed for user root
Feb 05 21:35:14 linux-sclt.site upowerd[1858]: usbmuxd_connect: Error: Connection to usbmuxd failed: Connection refused
Feb 05 21:37:27 linux-sclt.site kernel: usb 2-2: USB disconnect, device number 8
Feb 05 21:41:51 linux-sclt.site su[10320]: (to root) marguerite on /dev/pts/1
Feb 05 21:41:51 linux-sclt.site su[10320]: pam_unix(su:session): session opened for user root by marguerite(uid=1000)

Hello Marguerite,

  1. Because you’re referencing a systemd command that doesn’t exist yet in the version of systemd currently running on openSUSE 12.2, I have to assume you’re running 12.3 Beta (most likely). People in the Beta forum might be more helpful when using features not available in the current official release.

  2. IMO the syslog(journal) error seems clear… there is a problem properly setting up the device, apparently modprobe could not set up the iPad correctly. Nothing likely you can do unless you know the specifics connecting to an iPad and can then compare the device unit configuration.

  3. Your post seems more about simply mounting the iPad rather than jailbreaking.

HTH,
TSU

There was something about usb_modeswitching, causing MTP to fail, but I don’t remember exactly. JFYI.

Yes, I vageuly remember that too.

@MargueriteSu: I have seen some references to ‘libimobiledevice’ being required to provide the required protocols to support the iPhone/iPad/iPod devices. I have also read about tools such as ‘evasi0n’, but I’ll leave you to google those for your own interest.

Hi, deano ferrari,

Yes…I have libimobiledevice3 installed (seems it’s by default installed with Amarok)…

Can you be more presice? it’s a new tool (release yesterday), so I didn’t find any useful information throught Google actually…

Here’s the situation:

  1. Plug in iPad, the ‘evasi0n’ shows iPad 2 immediately.

  2. KDE Device Notifer jumps, and the iPad 2 disappears in ‘evasi0n’, so it seems Device Notifier takes over iPad2 as a Camera and a MTP device.

That’s why I’m confused, iPad can be recognized by ‘evasi0n’, BUT it is then gotten taken over.

Marguerite

That’s exactly what was described. I’ll have a look straight away.

Found it:

In /etc/usb_modeswitch, change this line:

DisableSwitching=0[/CODE]

to


DisableSwitching=1



Please let know if this does the trick. I don't own any Apple devices, so I can't test.

Hmmm… I wonder if the 69-libmtp.rules file contains a rule for your device (ATTR{idProduct}==“129f”). I don’t see an entry for your particular product ID though - it will depend on which libmtp version you have installed.

Ah, yes. I remember that trick with /etc/usb_modeswitch.conf. Hopefully, this is the key! :slight_smile:

Unluckily this Swiss knife didn’t work for me :’(