KDE desktop as default but Gnome desktop hangs

OpenSuse 42.1 with KDE and GNOME desktops

I have installed Leap 42.1 by selecting KDE Desktop as primary desktop and selected GNOME desktop in Software selection and now KDE desktop is working fine but when switched to GNOME during logon it just hangs. I have to kill Gnome service process using SSH from another PC.

Is it a problem to have dual desktops KDE & GNOME on the same installation ?


But there was a bug in GNOME that caused something like you described when using sddm as display/login manager.
Should be fixed by an update I think, did you install the latest packages?

The fix was to add “DesktopNames=GNOME” to /usr/share/xsessions/gnome.desktop, this was missing but GNOME depends on it.

Thanks Wolf323.

It fixed the dual desktops KDE and GNOME by adding “DesktopNames=GNOME” to /usr/share/xsessions/gnome.desktop file.

Great! :slight_smile:

But I checked, and an update to fix this has indeed been released for Leap 42.1, last November already shortly after the release of Leap 42.1.
So please update your system, if in doubt please post your repo list to see whether you have the update repo in your list and it is enabled.

zypper lr -d

zypper lr -d

repo-update is there in the list

9 | repo-update | openSUSE-Leap-42.1-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/

Yes, it is.
So you should have that line in that file.

Run “sudo zypper patch” to update your system.