[kde dead -- how to restore it without reinstall suse 11.1 ?]

Greetings !!

After have the gui completly f***d up with an upgrade that messed up kde, I’m about to restore the original kde from the installation dvd (11.1) but there is no particular options to only restore kde, so I have concerns concerning some of those applications compiled and installed after the original installation (two years backward). I also updated the kernel to make things work with vmware…
I don’t want to loose time to recompile all the different stuff I need to work with linux.

Is there a way to be sure (by renaming /usr /bin /sbin for example) to keep the kernel alive (with libraries and headers) and all applications that were working very good before I did this update for kde (I won’t do this again trust me)?

The kde group never told me how restore kde from the original dvd so I’m a little disappointed because the system is working ok in run level 3… only kde is dead.

I’ll dig deeper before doing the reinstallation of suse 11.1… if anyone have experienced such bad experience, it would be cool to tell me how to proceed, thanx in advance…

If you can’t get to level 5 this probably won’t work but may be worth a go:
try, from level 3, user login:

mv .kde4 .kde4-old

If that doesn’t work do this

Disable all but the official repos

then at level 3 become su -
and do

zypper dup

The “can’t go into runlevel 5” is a bit vague to me. When you run in runlevel 3 and then do init 5, aren’t there any messages? Doesn’t it say “run level 5 reached”?

Remember that simply runlevel 5 is not KDE. It only provides X with a GUI login (either kdm or gdm or similar). It is only after a user logs in that KDE or Gnome or other may be started.

A few notes:
CAF’s first suggestion is a good one (the ‘rename .kde4 tree’ approach) and often sorts out minor KDE problems, but

  • I get the impression that you might have a major KDE problem, in which case it won’t work. Still the first thing to try though, because it is easy (unless you are very short of space on the partition on which you have /home, that might give you pause for thought)
  • You might have kde3, in which case the tree to move would be called .kde. maybe that’s unlikely as kde3 doesn’t break as often…

Cases like this always make me feel that, for many people, having a backup GUI is a help (eg, installing both KDE4 and, say, XFCE and choosing at log-in time), unless you are a command line expert, which not all of us are. This always seems to happen at a bad time, and I don’t want to be out of my comfort zone as well as being under time pressure.

I was raised on the command line, yet it’s my practice, also for customers, to add a basic XFCE next to Gnome or KDE(4). Thanked myself for this at least a thousand times…

the system is working ok in run level 3… only kde is dead.

Is KDE dead? Did you do an update that changed the X server or your yideo driver?

What did you do just prior to the problem?

As already suggested you may not even getting as far as the kdm, gdm or other desktop manager and so may not be at the stage of loading KDE.

You can of course try installing XFCE or others in runlevel 3 as root with zypper or yast.

This may not help however if for example you were using a propriety driver you installed, and there was a kernel update in your update.

My soundcard (EWT88) won’t work anymore with “phonon” stuff (?)I tried to upgrade kde and then it is completly messed… there is no way to click on items and all items in task bar are grouped in one icon like they were all up the others… the menu button is freezed or sometimes it does something but there is no way to click on items…

When launching (when it works) an application all windows appears with no menu and no system buttons (minimize, maximize, close)…

All I wanted to do is to delete all stuff related to kde and then reinstall the kde environment from the original dvd but it didn’t worked as expected, there is no “expert” feature to restore only the X11 environment.

Now I’m working on windows because I have lotta work and I’m planning reinstall suse 11.1 and then try to upgrade the kernel and then reinstall all the stuff needed (hopefully I have the rpm and license keys)…

Have you tried

su -c 'zypper ref && zypper dup' 


How did you do this ‘upgrade’ ?

thanx for your help, I did the upgrade by yast, using online update… and I checked all the kde related stuff that seemed to be important (in red or major security update marked I can’t remember)… the wifi connexion died during the update and then at the next reboot… boom !!

That’s all… I have tried to remove the phonon (I’m not sure that the correct name of the framework) but the depencies were so deep that I aborted.

Now I’m in a location that the connexion is 100% sure (wired) so I’m sure that I could find a workaround to solve this issue.

I stay in touch…

Ok I solved it !

There is the different things (don’t be afraid) I did to solve it:

First save all the stuff bizness critical or fun critical in another directory than / (root) (on another partition is better). This point is the one that eat much of your time.

Second use the SuSE 11.1 install DVD and then boot on it, and select “update”

Be aware to never activate any repository once asked for enable one of those listed.

Just follow the instructions and let the process go untill the end, once rebooted, the kde environment will be restarted as it was the first time it was installed.

In my case it took 25 minutes to proceed…

And now, I can enjoy Linux in run-level 5 !!!