KDE custom File Associations openSUSE 13.1 not functional

I have tries several methods of making a new file association within KDE. There is nothing funny or custom about this install. It is a fresh install on a fresh user login. If I create a custom file extension it will not remember it. It creates the file mimeapps.list in the directory ~/.local/share/applications/ but dolphin nor the file association manager can find this information.

I am at a loss, I cannot find anywhere that this is an issue but I have tested this on multiple machines with the same results.

Any help on this is greatly appreciated.

My impatience is getting the better of me. The associations issue combined with my Bluetooth not working and Akonadi being as buggy as ever, I am going back to 12.3 until these matters can be sorted out. I can’t beta test on my “mission critical” machine.


I’m not quite clear what you are trying to do; you cannot add to the list of ‘Known types’ without submitting a patch to KDE. You can define a new filename pattern associated with an existing ‘Known type’ and a program to open it.

Note that ‘Known types’ that begin with x- are ones defined by KDE; so any patch you submit would have to be another x-* ‘Known type.’

Just a FYI
My preferred method to modify or add file associations…

Rt-click on a file of that type.
Select “Properties”
You will see a “File Type Options” button, click on it.

From there, you can either add a “viewer” application or re-sort the existing list.


That was another method I had attempted. I just thought I would only bring up the System Configuration method of doing it. No method of defining a file association works in KDE 4.11. Another method I used was using Crossover Linux automatic file association function create associations but whatever system in KDE that parses that directory of associations is not working. I did spend a lot of time Googleing this issue and tried it on several account logins and different systems. None worked.

Before reverting to 12.3, I decided I would give KDE 4.12 a try, I figured, there was nothing to lose anyway. So you are aware, custom file associations are no longer an issue in 4.12, as well as Akonadi is working properly and so is Bluetooth. I have decided to stay with openSUSE 13.1 for the time being.

So, to sum up, this problem was fixed by upgrading to the latest KDE 4.12 version.