KDE corruption/reset?

I left my laptop on last night with the lid closed (shuts off the screen and locks the session). When I opened the lid this morning (about 6-7 hours later) everything appeared to be as I left it. I opened firefox to do my daily routine of checking my school email and checking my social networking sites, when I realized the back button didn’t work in firefox (it was inactive, like when you open a fresh tab). It was a minor annoyance so I went to working on my schoolwork. When I went to open OpenOffice it said it couldn’t save my document because my /home directory didn’t have enough memory left. My system information showed I still have 12.5 GB left. So with these two glitches I decided to restart…bad idea.

When I got into my desktop again it looked like the configuration I had when I first installed OpenSUSE with the KDE 4.2 live cd. My wireless wasn’t even active (the green wifi button was unlit) and I had lost two of the three activities (desktops) that I had. So I restarted once again thinking maybe it’s just a weird glitch or something. Same result.

I restarted again and chose the failsafe option. While OpenSUSE was loading I saw a message that said the failsafe configuration was not found. It still booted up and the wifi button was lit so I’m not too sure what to make of this now. Anyways once in my desktop I still don’t have the other two activities and knetwork (kde3 knetwork because I couldn’t get the network widget to save my wireless settings) won’t even attempt to connect to my wireless router (usually after selecting my wireless router it shows the gears and then shows it’s connected, it wouldn’t even show the gears it just stayed greyed out.)

I switched my wireless handling back to Yast and am now typing this…but I just wanted to know if this has ever been a problem for anyone else and what I should do to avoid it happening again?

My computer specs are in my signature, my wireless card is a 1390 WLAN Mini-Card BCM4311 802.11 b/g

Try deleting or renaming the .kde* filed in your home directory. Log out an log in.

Hmm…Well…deleting the .kde folder caused all my settings to be reset. That’s normal. Had to re-enable compiz, but everything’s running slow now. Even before enabling compiz.

My WiFi light is still unlit. It lights up when I go to Yast’s network setup. I can’t use Knetwork because when I restart the computer my wifi isn’t enabled. Once I enable it I tried to start knetwork but it said network manager isn’t running.

I think I’m just going to reinstall. It takes like 10 minutes to reinstall over my / partition and all the headaches go away. I’m typing this from my vista side right now, but thanks for your help anyways :slight_smile:

After a 10 minute fresh install and about a half hour downloading all my programs back, everything is up and running just as fast as…a fresh install!
The Network Management widget even remembers my password! So now I don’t have to use kde3’s knetwork.
At least now I know not to leave my laptop’s lid closed when the computer is on for more than 6-7 hours.