KDE Control Center Samba Module

Okay. As many have done, I did my update to 11.0 yesterday, and before wiping the root partition on my 10.3 install, I grabbed my samba configuration file as everything else I was going to need was stored safely in my home folder.

Once 11.0 was booted up and I got rid of a few annoyances I began to set up samba, as there are others in my house that like to have access to my movies, music, etc, over the wireless.

I replaced the configuration by simply moving my old one into the /etc/samba/ directory. Big mistake, because now I don’t have it any more, and something is borked. In the KDE control centre, I can’t set any options for anything as it is all greyed out. It worked fine before I put in my configuration file, but once I did that, I can’t change anything at all. Also, the File Sharing module seems to have the same issue, for samba at least.

Here is an example.

I can use the config file, or the YaST tool, but I’d really like to have the KDE control centre modules working too. Any ideas?

Just in case, here is my /etc/samba/smb.conf file. It’s very basic because I tried removing as many options as I could to see if it fixed the control centre. The file sharing works over the network, just not the control centre module.

workgroup = TUX-NET
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = Yes
usershare max shares = 100
local master = Yes
preferred master = Yes
os level = 65
guest account = nobody
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = Yes
domain master = Yes
host msdfs = Yes
obey pam restrictions = Yes
pam password change = Yes
passdb backend = smbpasswd
security = user

comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

comment = All Printers
path = /var/tmp/
printable = Yes
create mask = 0600

comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

comment = Network Logon Service
path = /var/lib/samba/netlogon/
write list = root

hide files = New Document.odt/New Spreadsheet.ods/lost+found/
comment = Travis’ Documents
path = /home/travis/Documents/
guest ok = Yes

That smb.conf wouldn’t bork the kde configurator IMHO. It’s something else.
1: do you use KDE4 or KDE3?
2: Check in Yast → system → system services → runlevels → expert → smb and nmb both have checkmarks in levels 3 and 5 and that both are set to Running = Yes
3: check in Yast → software management that you have the following RPMs:

* • Base packages: samba, samba-client, libsmb-client, yast2-samba-client, yast2-samba-server, samba-doc
* • KDE users: kdebase3-samba
* • Gnome users: nautilus-share
* • For mapping/mounting network drives: cifs_mount & pam-cifs


Thanks for the response, I’m using KDE3, I should have mentioned that in the first post. Whoops.

The Runlevels are correct, and I have all of the packages mentioned. (Except for samba-doc)

I should probably mention, sharing is working,I would just like to have the ability to add or edit samba shares and settings using the control centre module, as opposed to the YaST tool and the smb.conf file.

Sorry, can’t help. I’ve not used that GUI.