KDE Connect volume control problem

There is a problem with volume control in KDE Connect.
Volume up, volume down and mute commands are not working anymore.





  - Volume down: qdbus org.kde.kglobalaccel /component/kmix invokeShortcut "decrease_volume"
  - Volume up: qdbus org.kde.kglobalaccel /component/kmix invokeShortcut "increase_volume"
  - Mute: qdbus org.kde.kglobalaccel /component/kmix invokeShortcut "mute"



I have noticed it today.

Shutdown, suspend, turn off and on screen commands are working correctly.

No one have this problem?

Not a TW or KDE Connect user, but just in case the following is relevant…

https://forum.kde.org/viewtopic.php?f=19&t=166094

Does this return true?

qdbus org.kde.kglobalaccel /component/kmix org.kde.kglobalaccel.Component.isActive

I read this article and I have noticed that I have not installed kmix. This is weird.
I installed it but it did not work.

This command above did not return true. It returns this:


Could not connect to D-Bus server: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes inc
lude: the remote application did not send a reply, the message bus security policy blocked the reply, the reply tim
eout expired, or the network connection was broken.


I think this is a bug.

Yes, it may well be. A quick check - create another user, and then start a desktop session as that user. Is the problem still evident?

I created another user. I have still this problem with volume in kde connect commands.

I have another system on my disk and this is MX Linux KDE 19.3. These commands work on it. And there is no kmix installed on system.
MX Linux has an older version of Kde Plasma 5.15. Maybe there is a problem with Plasma 5.20.3 on TW?

Report it as a bug…
https://en.opensuse.org/openSUSE:Submitting_bug_reports

I reported this as a Bug 117936.
No answer. It still is not working.

Can you provide a link to it?

This is a link:https://bugzilla.opensuse.org/show_bug.cgi?id=1179366

Ah, that explains why I didn’t find it (a digit missing in your previous post). These things may take time for attention of developers, so patience needed.

There is no response for this problem. There is a default feature in Kde Connect that is not working.

Bug 1179366 – There is a problem with volume control in KDE Connect. Volume up, volume down and mute commands are not working anymore. 430115 – There is a problem with volume control in KDE Connect. Volume up, volume down and mute commands are not working anymore.There is a problem with volume control in KDE Connect. • KDE Community Forums

No one even read it. It is strange.](https://bugs.kde.org/show_bug.cgi?id=430115)

At this time of year I’m not surprised about that.

To assist who ever is assigned to address your sound problem, it would quite likely help them better understand what your PC sound problem may be, if you attached the output of running this script in a konsole/xterm as a regular user:


/usr/sbin/alsa-info.sh

When prompted to either UPLOAD/SHARE or SAVE_LOCALLY, select “SAVE_LOCALLY”. Then go to the location /tmp and add the file that was saved by the script ( called /tmp/alsa-info.txt.xxxxxxx some number) to your bug report.

Hi Lee. This is not an ALSA issue though. If you read the first few posts, it appears to be desktop related, although the OP specifically identified it happening with KDE Connect.

Refer to post #4 (and linked KDE thread). For me this just works…

qdbus org.kde.kglobalaccel /component/kmix org.kde.kglobalaccel.Component.invokeShortcut 'decrease_volume'

with the output level dropping (as well as the on screen notification) each time it is invoked. (I’m currently using openSUSE Leap 15.2, KDE Plasma Version: 5.20.4, KDE Frameworks Version: 5.77.0,Qt Version: 5.15.2.)

It was an update of KDE Connect app in Playstore, ver. 1.16.0.
And now it works again!
All sound commands are working again.

Problem solved.
I hope so it will never appear again :slight_smile:

Thanks for the update.