KDE Connect not working

Recently updated to Plasma5, and downloaded kdeconnect-kde5 from wolfi’s repo and added it to the allowed services in the firewall, just like how it used to be for KDE4… but so far, KDE-Connect doesn’t recognize my device… anyone got it to work?

Same here. Remove wolf’s package and try with this one: http://software.opensuse.org/download.html?project=KDE%3AUnstable%3AExtra&package=kdeconnect-kde5

Hm, that’s basically the same package, because mine is branched from there (but installs to /opt/kf5/).

Unfortunately, I don’t use kdeconnect myself as I don’t have any supported devices. So I cannot test whether it works or investigate further.

So IIYC, the package from KDE:Unstable:Extra does work?

Is kdeconnectd started during login and running? (when using my package)

Other than that I have not really an idea what the problem might be…

I updated my package to the latest git version meanwhile, but I don’t really expect that to change anything. Before it was exactly the same source code as in KDE:Unstable:Extra…

IMHO the most likely reason for problems is that kdeconnectd is not running (as mentioned), or that the KDE4 version is running instead.

So answers to those questions might be interesting:

  • So/did you have kdeconnect-kde (the KDE4 version) installed as well?
  • Are you using my Plasma5 packages or the ones from the standard Tumbleweed repo? My packages explicitely add the corresponding directories below /opt/kf5/ to the XDG variables so that things like the DBUS service files are found. I think there was a change in Tumbleweed not too long ago that /opt/*/share/ is not added by default any more. And /opt/kf5/xdg/ will not be added to XDG_CONFIG_DIRS by the distribution, so the daemon is not started at all.
  • Is kdeconnect running and which one is it, i.e. what is the full path? Use the systemmonitor (Ctrl+ESC), search for kdeconnectd and hover the mould over the name to get that information, or run “ps ux|grep kdeconnect” and post the output.

It’s standard Tumbleweed from few days old snapshot. KDE 4 version wasn’t installed at all. I’ve changed XDG variables and everything works. Thanks wolfi323.:slight_smile:

export XDG_CONFIG_DIRS=/opt/kf5/etc/xdg/ 
export XDG_DATA_DIRS=/opt/kf5/share/

Ok, so the DBUS and autostart files were not found as suspected.

As indicated, it should work with my Plasma5 packages (from the same repo), because they modify those XDG variables on login. The distribution packages do not of course.

Unfortunately I cannot just change the kdeconnect-kde5 package to install those files to /usr/ and /etc/ or it will conflict with the KDE4 version (and the main point of my packages/repo is to be co-installable with KDE4). I’ll have a look at patching it to use different names, even for the DBUS service… (otherwise DBUS will just start the first one alphabetically I think, so either the KDE4 version or the KF5 version would not work)

Well, those are the reasons why having KDE4 and Plasma5 co-installable in the distribution/Tumbleweed is not really an option…:sarcastic:

If you don’t want/need to have both the KDE4 and the KF5 version installed, you can just as well use the one from KDE:Unstable:Extra as suggested by kasza_w_spreju. It’s basically the same package but installs to the standard system locations (and therefore conflicts with the KDE4 package).

I initially had both kdeconnect (kde4) and kdeconnect-kde5 installed but even after removing the KDE4 version, it didn’t work… and as you stated, I also found that kdeconnect was not started during login and was not running. I also have standard Tumbleweed. However, either installing from the repo as kasza_w_spreju suggested or adding those XDG variables does the trick and things work as expected, as I am just using Plasma5.

Thanks wolfi and kasza_w_spreju :slight_smile:

Well, thanks for the feedback! :slight_smile:

So it is not really a problem with my package.
I’m not sure if it’s worth the effort to rename the DBUS service, and I cannot test it either as mentioned.

But you could also try to install my plasma5-session-envscript package, that contains the script that sets up the environment to look in /opt/kf5 as well. And I modified the kdeconnect menu entry (months ago already) to run that if it’s installed.

But again, I’m not sure if that would help.

It definitely won’t help with autostarting the daemon on login, but the DBUS service should autostart it if it’s not running already. If that would work when starting the menu entry when the environment is not setup on login already I don’t know, as the dbus session daemon probably won’t be aware of that environment change (I’m not sure about all details regarding that).

Hi wolfie :slight_smile:

I checked as per your suggestion and installed kdeconnect from your repo and then installed plasma5-session-envscript but kdeconnect still didn’t work unless I installed from the other repo.

So it seems it needs more hacks to work properly, and in a way, it is more difficult for people using KDE4 and Plasma5 together…

Well, if you would use my Plasma5 packages, it should work I think… :wink: