KDE / CompizFusion Disaster


I am running openSuse 11.0 x64 version with KDE 3.5.9. Yesterday, I tried to run CompizFusion for the desktop effects. This was a huge mistake.

Things started to go wrong when my multiple desktops quadrupled. From there on in, things went from bad to worse. The worst problem I have is that KNetworkManager has disappeared from the system tray. I tried to re-add the applet and got the green world icon, but nothing happened when I selected it. It has now disappeared from the tray again and has also disappeared from the list of applets to add to the tray.

I believe that the settings remain as, if I log in as root, I can use KNetworkManager to select my appropriate network.

Secondly, my workspace switcher has gone. Again, the workspaces still exist as I can move apps to them, but I can’t change to the different workspaces. The taskbar no longer displays the available workspaces.

Finally, the window decorations went as well. I’ve managed to get them back, but only by disabling all desktop effects. I think I’ll live without these for now…

Can anyone help me with the first two? I’m still a relative Linux novice, so explanations need to be easy to understand…


OK - forget #2 - I’ve resolved the workspace switcher issue.