KDE clock partially hidden

Would like to know if anyone else has the silly issue of the KDE clock being partially hidden :
The first digit is not displayed. Running 11.2 MS-6 with a resolution of 1920x1080 on a HP DHX16 laptop with nVidia 9600GT.

That’s under KDE4.3 I’m assuming?

Have you tried deleting the old desktop settings in .kde4? That might fix it.

That’s done this way:

In graphic login screen hit Ctrl-Alt-F1
Login with username and password
Issue command below:

rm ~/.kde4/share/config/plasma* && exit

Now hit Ctrl-Alt-F7, login with username and password, and desktopsettings will be back to default, clean KDE4 4.3 settings. Refurnish your desktop to your needs. This way all your program settings (mail/chat accounts etc) will be kept.