KDE: Can't use shift button with application hotkeys

Hello. Old problem but I was too lazy to ask about it… :slight_smile: So, I can’t use the shift button with application hotkeys: for example, I tried to use copy-paste method in Konsole (ctrl+shift+C, ctrl+shift+V) - it didn’t work.
Or in other applications: Tried to use ctrl+shift+1 - nothing happens. I remember, in AntergOS KDE there was no a problem with hotkeys.

Another case: global hotkeys blocks application hotkey (Ctrl+Alt+l) used in Intellij Idea/Android studio for code reformatting but on Linux it blocks the screen.

Unless you did a special mapping,
You can copy and paste using your hot key combinations <without> the SHFT (ie CTL-c and CTL-v) in most normal Desktops (Different key combinations if you’re not running a Desktop).


So, it’s about to configure all needed applications’ hotkeys personally?

The key combinations I described are global, not application-specific.

Are the key combinations you’re describing configured by default for any apps? If so, pls list them.

Personally, I only use the key combinations you describe when I’m working in consoles, not apps generally.


Intellij Idea/Android Studio needs many hotkeys with Shift (and Ctrl+Alt+L)

Hm… Can I configure some global hotkeys to be less global in needed applications?

I just installed Android Studio 2.3.3 into a fully updated LEAP 42.3/KDE Plasma,
Is a new install, so nothing previously installed in the system.
And all hotkey combinations appear to work.

First, copy and pasted in and out of a Konsole stdout.
Then did various keystroke commands that use a SHFT in the key combination, and in each case saw the expected result.

Recommend you consider if you have a hardware keyboard issue…
Are you sure no alternate keyboard overlays are being applied, like Fn, Win, numeric keypad, etc?
Do you have another language installed or enabled other than English?
Have you modified <any> configurations that make your system non-default that you can think of?
Have you updated your system, eg running “zypper up”
When you say “old problem” do you also mean that your system has undergone upgrades from previous versions of openSUSE?

At this point, all I can say is that in a <default install> I can’t replicate the problem you describe.


I mean that problem was since my first openSuse KDE installation. That problem was also on Manjaro KDE previously. But not on Antergos
My keyboard is simple and haven’t Fn and media keys.
So, you say in Android studio there is no problems for you to add bookmarks (ctrl+shift+1…0), reformatting code with ctrl+alt+L etc?
Yes, I have another language - Russian. Is it a problem?
Have you modified <any> configurations that make your system non-default that you can think of? - don’t think so
Have you updated your system, eg running “zypper up” - latest version as I know. Today was an update.

It looks like this old patch was not included in OpenSUSE

And the bug was reported in 2004
Detailed: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/36812

In 2011 we still had KDE4, I’m not even going to talk about a 2004 GNOME bug. These bugs have nothing to do with your current issue. IMNSHO.
Both in Leap 15.0 and in TW I have no issues using f.e. Ctrl-Shift-C and -V, nor do I have issues with hotkeys that include a Shift.
Concluding: I think you’re barking up the wrong tree, and need to investigate the settings in your home dir. Please confirm, that the issues exist for a newly created user.

The bug persists with a new created user.
The bug occurs if the language switch hotkeys are Ctrl+Shift.
The bug haven’t been found in KDE Manjaro last usage.
The bug resolving workaround: change language switch hotkeys from Ctrl+Shift.
The bug comment in a bugtracker:

Alon Bar-Lev 2007-08-17 12:43:29 UTCI have the same issue with Hebrew layout…
<Alt><Shift><Tab> changes language on <Alt><Shift> key-down and not go back window as expected.
Well… long time until I thought I should file a bug… :slight_smile:

It basically effects all multi-language users, and regular users are not able to accept the keydown/keyup explanations…

what’s up? How many languages do you use with the (default) Ctrl+Shift switching?