KDE - Can't Unlock Screen

Trying to unlock the screen in KDE (4) gives me an error “Cannot unlock the session because the authentication system failed to work; you must kill kscreenlocker ([PID]) manually.” Killing the PID that it gives me does unlock the screen, but doesn’t exactly coaunt as a solution. I’ve tried reinstalling most of the KDE packages (kde4-, kdebase4-, and kdelibs4-*) as well as PAM (which I assume is what it uses for authentication). I’ve also tried re-setting my password. Any help would be much appreciated, as this is a really annoying problem.

Update - Google gave me a lot of results that said to make sure kcheckpass is setuid root. It is, so that is not the problem.

Invoking kscreenlocker manually from a terminal and killing it gives this message:

Xlib:  extension "XFree86-Misc" missing on display ":0.0".

Trying to unlock it adds this:

Cannot open lockfile

Permissions on /var/lock are drwxrwxr-x. I am a bit suspicious though as the owning group is uucp. Is that normal?

Still trying to fix this.

drwxrwxr-t 6 root root 4096 jan 11 09:04 /var/lock

This is my output of ‘ls -ld /var/lock’

I set the permissions to match that – no luck.