(KDE): Can't login with second monitor connected

Hi all,

I’m using a Lenovo Y510p which I recently upgraded to Tumbleweed.
Everything worked fine till I tried to connect my second Monitor via the HDMI Port. When the monitor is connected I’m not able to login to KDE anymore.
After entering the login credetionals the openSUSE “progress bar” appears and after half of the progress both screens turn black and I’m dropped to the login screen again.

The same issue appeared when I tried to connect the monitor after the successful login: The screen turned black and I was droped to the login screen again.

Any hints?

Thanks in advance!

EDIT:

This is what dmesg said after pluggin in the monitor:

 2748.640326] kactivitymanage[2010]: segfault at 7f73f7962d10 ip 00007f73f7ba6aa1 sp 00007ffe81932f28 error 4 in libQt5Sql.so.5.4.2[7f73f7b91000+3f000]
 2748.950354] nouveau E    PBUS][0000:07:00.0] MMIO write of 0x00000000 FAULT at 0x418880  IBUS ]
 2748.950428] nouveau E    PBUS][0000:07:00.0] MMIO write of 0x00000000 FAULT at 0x418e08  IBUS ]
 2748.950444] nouveau E   PIBUS][0000:07:00.0] GPC0: 0x419f74 0x00000555 (0x3800820c)
 2748.950462] nouveau E    PBUS][0000:07:00.0] MMIO write of 0x00000010 FAULT at 0x418980  IBUS ]
 2748.950480] nouveau E    PBUS][0000:07:00.0] MMIO write of 0x00000002 FAULT at 0x4188ac  IBUS ]
 2748.950492] nouveau E    PBUS][0000:07:00.0] MMIO write of 0xbadf1008 FAULT at 0x419cc0  IBUS ]
 2748.950507] nouveau E   PIBUS][0000:07:00.0] GPC0: 0x419cc0 0xbadf1008 (0x3800820c)
 2748.950541] nouveau E    PBUS][0000:07:00.0] MMIO write of 0xbadf1000 FAULT at 0x419eb4  IBUS ]
 2748.950556] nouveau E   PIBUS][0000:07:00.0] GPC0: 0x419eb4 0xbadf1000 (0x3800820c)
 2748.950590] nouveau E    PBUS][0000:07:00.0] MMIO write of 0x00000000 FAULT at 0x405804  IBUS ]
 2748.950615] nouveau E    PBUS][0000:07:00.0] MMIO write of 0x00000001 FAULT at 0x40581c  IBUS ]
 2748.950835] nouveau E   PIBUS][0000:07:00.0] HUB0: 0x404170 0x00000012 (0x0e008201)
 2750.387537] wlp9s0: deauthenticating from 14:cc:20:f0:ed:8f by local choice (Reason: 3=DEAUTH_LEAVING)
 2750.411409] cfg80211: Calling CRDA to update world regulatory domain
 2750.412824] cfg80211: World regulatory domain updated:
 2750.412826] cfg80211:  DFS Master region: unset
 2750.412827] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
 2750.412828] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
 2750.412830] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
 2750.412830] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
 2750.412832] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
 2750.412833] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
 2750.412834] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
 2750.412834] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
 2750.412835] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
 2750.952458] nouveau E  PGRAPH][0000:07:00.0] HUB_INIT timed out
 2750.952465] nouveau E  PGRAPH][0000:07:00.0] 409000 - done 0x00000204
 2750.952475] nouveau E  PGRAPH][0000:07:00.0] 409000 - stat 0x00000000 0x00000000 0x00000000 0x00000000
 2750.952484] nouveau E  PGRAPH][0000:07:00.0] 409000 - stat 0x00000000 0x00000000 0x00000002 0x00000009
 2750.952487] nouveau E  PGRAPH][0000:07:00.0] 502000 - done 0x00000300
 2750.952492] nouveau E  PGRAPH][0000:07:00.0] 502000 - stat 0x00000000 0x00000000 0x00000000 0x00000000
 2750.952496] nouveau E  PGRAPH][0000:07:00.0] 502000 - stat 0x00000000 0x00000000 0x00000000 0x00000000
 2750.952498] nouveau E  PGRAPH][0000:07:00.0] init failed, -16



Filed a bug: https://bugzilla.opensuse.org/show_bug.cgi?id=944481

Looks like nouveau is crashing.
So installing the proprietary nvidia driver might help, although that can be a bit tedious on Tumbleweed: you need to do it “the hard way”, and you need to reinstall it after certain updates like the kernel.
https://en.opensuse.org/SDB:NVIDIA_the_hard_way
Also, the driver does not work with Kernel 4.2.0 yet AFAIK. TW still has 4.1.6, but that will be updated to 4.2.x (with x=1 probably) at some time.

You could also try to disable the “KScreen 2” service in systemsettings5 (“Configure Desktop”)->Startup and Shutdown->Background Service, to see if it’s related to KDE detecting the monitor.

Unless the issue was originally resolved at some time (I never heard that it was, only “that the problem is being worked on”), this sounds very much like what was reported several years ago (openSUSE 12.3?) running KDE4 (IIRC).

There was no resolution at that time.
You just had to disconnect the 2nd monitor either when initially logging in or waking up from suspension.

You could also see the basis for why this was happening, whenever you connected the 2nd monitor, it became your primary display (which also became an issue when connecting to a projector).

TSU