KDE and Modem install

I have ditched Gnome and installed KDE. During the install, When it got to the checking the modem stage,I configured it for my isp. I set it to /dev/modem0, which in hindsight, I dont think was good. I believe it shouldve been to /dev/ttyS0. The modem is a Motorola SM56K fax/data modem and was working ok under Windoze.

After the install was complete , I went into the modem settings to change it using Yast, to ttyS0. It seems to be stuck on modem0 but when going into the “Details” settings of the modem, it shows as ttyS0.

I tried dialing in with this modem and got the following from the logs:

Sending ATM1
sending ATQ0
Resedning ATM1
. . .
Modem not responding
Connect scrip failed exit code 8

So I configured the modem again, this time selecting ttyS0 vice modem0. However, it still shows modem0 in Yast. When checking the “Details” of this config, there are some preconfigured ini strings, which I left.

When selecting this modem to dial in with, the logs show no modem detected. I then tried deleting all modems and starting again but I cant seem to delete the “default” modem setting, modem0.

Is there a modem config file I can edit or delete and set it up to use ttyS0, or any other port ?


What did you use to configure you,re modem ?
Kinternet perhaps ?
In the past kinternet was rather easy to use.


Modem0 is normally linked to the appropriate tty. That isn’t the problem. The problem is that the modem is not responding which could be because your need to use ndiswrapper with it or it could be something else.