KDE and LXDE won't start ; Xterm okay

Hello everyone,

Since this morning, I’m having a problem which symptoms are similar to this one : Cannot Login, KDE won’t start - OpenSUSE 11.3, but it affects only one user.

Everything was fine yesterday, but now, everytime this one user tries to start his KDE session, the screen goes black for a few seconds before coming back to the login screen.

I tried the following :

  • I installed LXDE and tried to log in : same problem

  • I tried to log in Xterm : no problem

  • I created a new user and tried to log in : no problem, be it KDE or LXDE

  • I cleared /tmp : same problem. My /home partition is 98% full but still has 2-3GB available. The / partition is 45% full with 28GB left.

  • I went through ~/.xession-errors, .Xauthority and .dmrc in search for error : no result, only information or warnings

  • I checked /var/log/xdm.errors, Xorg.0.log, kdm.log, localmessages : no useful hint, but I’m not too familiar with them so I may well have missed some things.

From what I’ve gathered so far, it seems the problem is user-specific, graphical session-sepcific, but not desktop-specific (since both KDE and freshly installed LXDE fail in the same way)… and now I don’t know what else to try. Here’s where I call for help !

I can post any log needed (I left them out in order to prevent clutter).

Thanks in advance to whoever will read ! :slight_smile:

My setup :
OpenSUSE Tumbleweed
Linux #1 SMP PREEMPT 2011-07-21 02:17:24 +0200 x86_64 x86_64 x86_64 GNU/Linux

Addendum :

If I log in as another user, open a konsole, su to the problematic user and try to start Firefox or Kopete, here’s what I get :

breversa@cathedrale:~> firefox 
GLib-GIO:ERROR:g**dbus**connection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
breversa@cathedrale:~> **
GLib-GIO:ERROR:g**dbus**connection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)


breversa@cathedrale:~> kopete&
breversa@cathedrale:~> kopete(11012): KUniqueApplication: Cannot find the **D-Bus** session server:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 

kopete(11007): KUniqueApplication: Pipe closed unexpectedly.

Firefox is a GTK application, while Kopete is a Qt one, but both error seem somehow related to DBUS (I highlighted the references is the above boxes)… Is that a hint ?

You say your /home is at 98%. Normaly it should stop at 95% and then give a lot of problems (like yours). That would mean that you have changed that leeway percentage. Are you aware of that? Thus when it is not set to 5 (the default reserved-blocks-percentage), but at 2 you are now full, Only when it is set to less then 2 (1 or 0), you can use those last GBs you have.

I am not sure why new users can log in, except that creating to standard files in those users home directories is done by root, which is not hampered by the reserved-blocks-percentage and that just login from the new user does not need new space. Try to create a file with such a new user to be sure.

What I also do not understand is what you mean by

  • I tried to log in Xterm : no problem

Do you mean you loged in into the GUI as another user and then used an xterm there to do a CLI login of the affected user?

The problems in your second post might be something different. I do not think that starting any of those Internet going GUI applications do bring significant information for your problem. Also, as you do not copy/paste here what you do, I am a not quite clear what you do there.

su <user>


su - <user>

When you did some commands you want to let us look at, then please copy/paste and no stories.

PS you can check the reserved-block count with

tune2fs -l /dev/sda? | grep 'Reserved block count'

where you have to fill in the partition number of yopur /home partition instead of the ?.
As this is in blocks, you have to calculate a bit to get to the percentage, or compare the number with what you think you can still use.

I have similair problem when i try to login - kicked back to login screen… i started a failsafe and wrote startkde and then kde started but i can’t login normally

I use 11.4 with tumbleweed and kde4.7 repos…
I did manage to get it working with zypper dup… now i can login again.

Oh, pleae, please @hype0.

  1. Do not hang on your problem at someone elses problem when you are not 100% sure that it is the same problem. Now we are getting a very confusing thread.
  2. When you use Tumbleweed, please post in the Tumbleweed forum! That is where your fellow Tumbleweed users are to help you.

There are a couple of similar threads in the Tumbleweed forum. As best I can tell, an update broke gpg-agent. Since the session startup often uses gpg-agent, that breaks session startup.

The chances are that is your problem too. Check the other threads, particularly:
xfce session crashes immediately after login

Ok sorry for that.

Hello hcvv, and thanks for your time;

Here are the information you requested :

1- When I said “I tried to log in Xterm”, I meant “If I choose Xterm (it’s labeled “rescue”, IIRC) as session type (the same way I select KDE or LXDE), I don’t have any problem”.

2- You’re correct with the “su - <user>” thing : I did forget the “-”. My bad ! I routinely use this syntax though, but only to become root, not another user… Thanks for the reminder. :slight_smile:


cathedrale:/var/log # tune2fs -l /dev/sdb1 | grep 'Reserved block count'
Reserved block count:     1953612

That makes about 1.86GB, right ? But as said earlier, sdb1 has 3,1GB free right now.

@nrickert :
Hi ! Now that you mention it, I did notice something related to GPG in some log… I did not pay much attention to it though, because I didn’t think it had anyting to do with my problem. I’ll try to find that log later tonight and get back to you after following the instructions in your link ! Thanks ! :slight_smile:

Well, xterm is just another X based terminal emulator program like konsole (in fact it is the oldest one, did exist even before a real Desktop Environment was created). It only runs when you are using in the GUI. Thus I guess you did not use xterm. Better do not call it that. You confuse people. Like the su/su - case, it is better to explain extensively what you do (and support this by copy/pasted evidence or screenshots when possible) then to tell stories. Because other people may have a complete different understanding of the words you use.

BTW, I do see neither Xterm, nor rescue in the list of possible sessions in my kdm screen, but that is not important for your problem imho.

My apologies, you’re right. As for the “rescue” entry in my session list, it’s called “de secours” in french (my language). It believe it may be called “failsafe” in english, but never mind.

I’ve found the log mentioning GPG :

breversa@cathedrale:~> cat .xsession-errors
/etc/X11/xim: Checking whether an input method should be started.
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale fr_FR.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
/usr/bin/gpg-agent: relocation error: /usr/bin/gpg-agent: symbol __assuan_socket, version LIBASSUAN_1.0 not defined in file libassuan.so.0 with link time reference

gpg-agent is provided by the gpg2 package, which was indeed upgraded from the Tumbleweed repo. I’m gonna downgrade it (= use another provider) and see what it does. If that solves my issue, this topic will have to be moved to the Tumbleweed forum.

Do I need to worry about the input lines above ? I don’t think so, as my test user has the same lines in his .xsession-errors, and can log into KDE without problem.


nrickert was right : the login failure is caused by gpg2-2.0.17-6.2.x86_64.rpm from the Tumbleweed repository.

I downgraded to gpg2-2.0.16-7.1.x86_64 from the standard OpenSUSE 11.4 repository, and everything works flawlessly again !

Thanks a lot for your quick and helpful replies ! You really saved my day. :slight_smile:
I’ve learned not to ignore any error in a log, even if it looks only remotely linked to the issue at first sight.

May I ask a moderator to move this topic into the Tumbleweed forum ? I’ll modifiy the title to add “[SOLVED]”.

Actually, upgrading libassuan from 2.0.1-4.1 from the standard repo to 2.0.2-4.1 from Tumbleweed also fixes the issue. Why it was not selected along the other upgrades escapes me…

EDIT 2 :
Is there really a way to modify the topic’s title ?

We do not change the titles and saying in a post that you consider it solved is OK here.

Enjoy. And please, as long as you use T, next time start your thread there from the beginning.

And as an extra: I do have those first lines also in my .xsession-errors.

I will, sir. Thanks again ! :slight_smile: