KDE Activity

with the holiday time i’m looking into kde activitys :wink:
a question about that, is there a way if you switch to another activity that also starts a few programs, like kate of firefox?

I’m running the latest RC 4.9.95 :wink:

It should be. From what I’ve read you have to open the apps desired in the activity desired, then stop the activity, save the session, and have KDE open the saved session when starting. Starting the created activity then should open the apps.

do you mean “save the session” in the systemsettings of kde?
otherwise, it doesn’t work in the activity bar to save with open apps.

Using 12.3M2 (with KDE 4.9.90),

I logged into a test account (no prior KDE configuration).
I turned off desktop effects, logged out, logged back in. (I’ll explain why, below)

I started an “xterm” in the “Desktop” activity - that’s the one that shows up on boot.
Using the activities manager, I switched to the “Desktop Icons” activity, and started firefox.

I then switched back to the “Desktop” activity, and logged out with those commands still running.

On login, xterm was automatically started in the “Desktop” activity, and firefox was automatically started in the “Desktop Icons” activity.

I’m pretty sure that if I have configured the desktop to start with a previously saved session, and if I had then saved the session with the xterm and firefox running, it would have started those applications on the next login.

On the “desktop effects” matter: I first tried this with the default of desktop effects enabled. When I started firefox, that crashed the nouveau driver. The only way to recover was to power off. After reboot, I deleted all of the desktop startup configuration (actually, did that remotely, with an ssh login). Then I started over.

hum, i’m not able to start programs if i change to another activity.

What i want is open a activity “photo” that will start dolphin & gimp
and not on logon that he will start all the programs in all the activity

system openSUSE 12.2 @ KDE SC 4.9.95 / 64bits.

I start my KDE with empty session (in system settings of KDE)
run activity 1 –> open firefox
change to activity 2 –> open dolphin
change back to activity 1 –> OK, firefox still running

log out KDE, then login
activity 1 is open but no firefox running
on activity 2 no dolphin open

Create a new user and test that.

no need, but that did the trick if i was testing in the new user :shame:
the problem for me was: didn"t “stop” the activity first

i’m now able to start a activity and opening the apps that i want

btw many thx

Okay. If you are configured to start with an empty session then of course when you logout and login again, you will have an empty session.

If you want login to start with the previous session, then you need to instead set that to restore previous session

Alternatively, set it to restore manually saved session which is what I normally use except when testing. With that setting, I get my session exactly how I want it, then I click on the menu button at left of the panel (bottom left of screen), move the mouse over the “Leave” button at the bottom, the click on Save Session.