I installed KDE, barely anything runs. Would I fare better with GNOME while KDE matures?


GNOME? have only ever used kde and run with the current TW

most things work,

  1. tvtime has been lost, from posts this will not be updated,
    but qv4l2 is useable as a replacement
  2. before plasma5 kaffeine was lost but vlc works just as well

installs are on both 32/64 bit OS’s both PCs/laptops

each installs has odd little quirks but nothing major

OS status – openSUSE-release-20150722-1.2.x86/_64

maybe you are unlucky with your hw

what are your repos’?

all is running ok on Toshiba SM60, not sure if this is older than
the IBM ThinkPad T21


And what do you mean with that?
Kaffeine is part of the standard Tumbleweed OSS repo just as ever.
Maybe it isn’t installed any more on TW by default, no idea, but it should work if you install it manually.

The same applies to tvtime.

Can you please elaborate what you mean exactly with “barely anything runs”?
There is no “KDE 5”.
Do you have problems with the desktop?
Or with applications? (if yes, which ones?)
And what kind of problems?

Chrome will not install (aborted by user?!?), Steam will not run (Nouveau), Docky & Plank icons cannot be themed with Cairo Dock extensions not installing (dependency issue) so useless.

That’s completely unrelated to Plasma5.
Use YaST, zypper or rpm to install it.

Apparently PackageKit doesn’t work at the moment in Tumbleweed, at least there’s another thread about that.

Steam will not run (Nouveau),

I doubt that’s related to Plasma5.

Maybe try to install the nvidia driver?

Docky & Plank icons cannot be themed with Cairo Dock extensions not installing (dependency issue) so useless.

And I don’t see any relation to Plasma5 there either.

If you want to try another desktop, please do. You can have as many installed as you want and choose between them at the login screen.
But that probably won’t help at all with your problems.
Better ask about them (in a separate thread for each problem), with more information about the problems (e.g. at least error messages).

hi wolfi323

updated today to the most recent packages then tried again with the same results,

  1. kaffeine-1.2.2-30.1.x86_64
    music, mp3, ok

dvd’s, ploblems with start menus,
after the initial menu appears nothing can be selected until the mouse pointer changes form an arrow to a hand, about 20 seconds, then selection is possible if the hand is placed over the area where the blue triangle should be showing

if a selection is made, the second level menu appears after the piracy warning,
sometimes it is visable for about 5 seconds then the screen goes black with only the mouse pointer visable, but again if the mouse pointer is place over the area where selection is possible a blue triangle appears, which allows selection

so the first time this happens the selection is abitrary until the ordering is memorised from the prior screen flash

NB no such problems playing dvd’s with vlc

  1. tvtime-1.0.2-264.3.x86_64
    and all prior version since initial update to openSUSE13.2

on initialisation the OS is frozen with the exection of the mouse pointer,
all stops dead even the System Monitor displays

cannot see any failure or logging events, only recovery is to powerdown/up hw

from memory no such problems running tvtime within iceWM

  1. install:-

NB. no problems found using vlc and v4l instead


Well, that’s something completely different than “Kaffeine and tvtime have been lost”, isn’t it? :stuck_out_tongue:

I tried Kaffeine with the one DVD (image) I found, and indeed the menus didn’t work. But switching between windowed and fullscreen mode (double-clicking or pressing ‘f’) fixed it.

This has nothing to do with Plasma5/kwin5 though, I see the same in KDE4, and even IceWM.

Kaffeine is just a frontend to libxine though, strange enough xine-ui doesn’t seem to have this problem.
(Actually work started some time ago to port Kaffeine to use libvlc instead, but this never was finished I think, at least it hasn’t been released yet)

And I see the same problem as you describe with tvtime too, it seems to make kwin5 crash/freeze (works fine in KDE4). This might be worth a bug report.
Btw, it’s not necessary to powerdown/up the hardware, just switch to a text mode console (Ctrl+Alt+F1 e.g.) and “killall -KILL kwin_x11” (you can start kwin again afterwards by typing “kwin_x11” into the Alt+F2 dialog).
Without kwin running, tvtime works even.
As a side-note, I never liked or used tvtime anyway. I always preferred xdtv (and still use it), a fork of xawtv which even has recording facilities:
I package it myself, I don’t build it for Tumbleweed at the moment but can if you are interested.
This does work fine in Plasma5 too.

But as mentioned, the OP’s “problems” do not seem to be related to Plasma 5 at all or it having problem with the graphics or other hardware.

FYI, I tried to install a downloaded rpm package with Apper/PackageKit in an up-to-date Tumbleweed VM meanwhile, and it worked perfectly (except for a graphical glitch in the progress dialog, this is a known problem with the breeze theme).

So probably there was some other problem, like Conflicts or disk full. PackageKit may even give wrong/misleading error messages in those cases, I think there’s even a bug report about PackageKit stating the update “has been aborted by the user” if the disk is full.

Anyway, as I said that’s totally unrelated to “KDE 5” and will probably be the same with any desktop (if using PackageKit).
And again this shows that it’s better to actually state ones problems, than just writing “anything barely runs”.
How should anybody be able to answer the question whether he would “fare better with GNOME” with such information? :\

The problem descriptions are still far too vague after the clarification though.
I’d say you’d probably would not fare better with GNOME, but rather have the same (or even additional/different) problems.

Steam not running might rather be a problem with nouveau, that’s still not the best choice for gaming.

And how should a different desktop change the “Cairo Dock extensions not installing (dependency issue)”?

It would seem my problems are because I am too stupid. I’ve been a ******! The last time I used openSUSE, everything just worked (till I added repos will-nilly.) I have been disrespectful towards the 90% working versus the 10% Polish, so all you Poles out there?!? (In no way dissin’ Linux or Poles.) I am willing to learn honest guv. But my post comes across screaming me me me whilst remaining vague on detail.

To pick one just the one issue;

I am trying to load pepper flash plugin for Chromium. I have added the community repo in YaST (source, though not debug) YaST Software management will crash on launch, but “chromium-pepper-flash” plugin is not showing in Apper. This process was documented as of June 2014, has anything changed wolfi? Forgive my ignorance.

YaST->Software Repositories worked, but Software Management is crashing?
Strange, and shouldn’t happen. There is a recent bug report about that though: https://bugzilla.opensuse.org/show_bug.cgi?id=939359 , although that definitely is not a general problem AFAICT.

As a workaround you can just install it with zypper:

sudo zypper install chromium-pepper-flash

It should show up in Apper too though.
What repo exactly did you add? “source, though not debug” would sound wrong. The source repo contains the source code for all packages included in openSUSE, it is no “community repo”.
Can you please post your repo list? This is only available in Packman, you need to add that repo.

zypper lr -d

This process was documented as of June 2014, has anything changed wolfi?

Not really.