KDE 5 second delay on logout/shutdown/reboot


I actually have had this problem for years, so it is not necessarily related to the latest opensuse but somehow this never gets resolved. In the past months I installed leap 42.2 freshly on several desktops and vm’s and they all exhibit this same behavior: when you shutdown, logout or reboot, there is a delay of 5 seconds before the procedure executes. In the case of shutdown, the funny thing is the shutdown is immediate if you type it in a terminal, so I guess it must be something KDE related. I have not tried opensuse Gnome.

At one time, I thought it was a systemd timeout configuration concerning inhibitors, see your list:
sudo systemd-inhibit --list


there is even a nice kde system module to view the configuration:
but unfortunately this “InhibitDelayMaxSec” does not seem to change anything and wouldn’t delay the logout, I guess.

Assuming everyone else must be having this delay too, does anyone have any idea where this delay is coming from? On a fast pc especially, this is driving me nuts :slight_smile:


Okay, so guess what: the problem is fixed in leap 42.3! Now I feel really stupid for not checking earlier :slight_smile: I didn’t expect the situation to have changed after all those years …

now I can finally do an immediate shutdown using ctrl+alt+shift+pgdn again! =) I did find a new bug related to leave options in the start menu, but that’s another issue :slight_smile: