KDE 5 and foreign characters in file names

For years, I have had umlauts and all sorts of foreign characters in file and directory names without any problems. Since kde 5, however, these cause problems in several ways. Just two examples:

  • files with umlauts in their names that come as e-mail attachments through thunderbird can no longer be handled other than by “save as” and then renaming them - I cannot anymore open them by simple clicks
  • directories with umlauts in their names have become unreadable for any kde applications (e.g. parts of my music library are no longer accessible by clementine

How to fix that?

Have you checked under System settings>Appearance>Fonts (in KDE4l not sure if it is the same in KDE5)? It is possible, though unlikely, that the default font which is used for your folders lacks support for some characters.

I am not sure that that is what he says.

IMHO the complaint is not that the characters are not shown correctly, but that KDE does not seem to handle them in the same way as when file names have only the old ASCII subset of Unicode characters.

In other words, even if the file names would be shown with open squares or ? in black (depends on what software uses what for characters not found in anny font), the graphical actions like clicking on the names should still function.

I have this directory:

drwxr-xr-x 2 henk wij  4096  1 apr  2014 नमस्ते

and when I click on it in Dolphin, Dolphin switches to it’s contents. But I am using openSUSE 13.1 and KDE 4.
This seems not to function in the OP’s environment.

Thanks, but indeed that is not my problem. I see all these characters perfectly well, but the applications do not interpret them correctly and return an error message saying that this file does not exist. A very big nuisance, particularly since this has worked well for so long.

(I remember the days where one avoided those characters at all costs, due to the linux-windows-mac incompatibilities, but I thought this is history. And anyway, here in France, most people send attachments with accents and other funny characters in their names)

So I hope there will be a solution!

FYI: running Plasma5 here ( on 13.2 and TW and Leap beta ) and I don’t see the issue here, so it’s probably not a KDE issue. It wouldn’t be wrong to check the regional settings though.

[QUOTE=Knurpht;2730488. It wouldn’t be wrong to check the regional settings though.[/QUOTE]
While checkig is never a bad thing, I doubt if it is the regional settings are important here.

In my example above, I do not have any setting pointing to Devanagri and/or Hindi. Mu user environment is NL and the system environemnt is default.

And those characters are not “funny”, they are nowadays normal Unicode points encoded in UTF-8.

A question, are those files on a native Linux file sytem?

And another one. Can you please post an ls -l of an example file, or directory with those files?

ls -l example

How did you install Plasma5?
Please, show output of

zypper lr -d

absolutely, ext4, and the system has not changed for years - this big however is new

this is a little difficult since the normal case is the one where (as I described above) an attachment arrives with non-standard characters in it (here in France, often with an “é”), and then thunderbird will not be able to save that file to disk or allow libreoffice to open it.

zypper lr -d
#  | Alias                                  | Name                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                 | Service                                                                                                                                                                
---+----------------------------------------+---------------------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------------------------------------+--------                                                                                                                                                                
 1 | Archiving                              | Archiving                                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Archiving/openSUSE_13.2/                                  |                                                                                                                                                                        
 2 | KDE_5_Framework_Factory                | KDE 5 Framework Factory                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Factory/                        |                                                                                                                                                                        
 3 | KDE_Frameworks_5                       | KDE Frameworks 5                            | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/                           |                                                                                                                                                                        
 4 | Kernel                                 | Kernel                                      | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/Kernel:/stable/standard                                   |                                                                                                                                                                        
 5 | Qt5                                    | Qt5                                         | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/                                   |                                                                                                                                                                        
 6 | download.opensuse.org-4.4              | openSUSE BuildService - LibreOffice         | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/4.4/openSUSE_13.2/                           |                                                                                                                                                                        
 7 | download.opensuse.org-Extra            | openSUSE BuildService - KDE:Extra           | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.2/                                 |                                                                                                                                                                        
 8 | download.opensuse.org-mozilla          | openSUSE BuildService - Mozilla             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.2/                                    |                                                                                                                                                                        
 9 | ftp.gwdg.de-suse                       | Packman Repository                          | No      | ----      | No      |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/                                            |                                                                                                                                                                        
10 | home:wolfi323:branches:KDE:Frameworks5 | home:wolfi323:branches:KDE:Frameworks5      | No      | ----      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_13.2/ |                                                                                                                                                                        
11 | isv_ownCloud_desktop                   | The ownCloud Desktop Client (openSUSE_13.2) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/openSUSE_13.2/                     |        
12 | libreoffice_5                          | libreoffice 5                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Factory/openSUSE_13.2/                       |        
13 | opensuse-guide.org-repo_1              | libdvdcss repository                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                                                |        
14 | repo-non-oss                           | openSUSE-13.2-Non-Oss                       | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                                        |        
15 | repo-oss                               | openSUSE-13.2-Oss                           | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                                            |        
16 | repo-source                            | openSUSE-13.2-Source                        | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.2/repo/oss/                                     |        
17 | repo-update                            | openSUSE-13.2-Update                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                                           |        
18 | repo-update-non-oss                    | openSUSE-13.2-Update-Non-Oss                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                                                   |        
19 | science                                | science                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/science/openSUSE_13.2/                                    |        

I read your description above as more general. Do you mean that this behaviour is only with mail attachements that are handled through Thunderbird? In that case we should maybe pay more attention to Thunderbird and not to KDE as your titles says.

My 2 cents: Your repos are a mess. F.e. you have two Frameworks5 repos, one for openSUSE_Factory, which should be openSUSE_13.2, the other wolffi’s.
Before we can do anything about this aledged foreign character issue, you need to sort out your repos and use zypper to make sure packages come from the appropriate repos.

The problem you’re describing is typicallyrelated to implementing unicode properly.

If you Google “unicode plasma5” you might find the hits useful…
The first Reddit hit describes one User’s fix…
The following link to a KDE blog describes (with screenshots) configuring your text encoding, how it’s configured in KDE and a lot more
https://blogs.kde.org/2014/09/11/beyond-unicode-closing-gap-support-mixed-character-set-text-kde-workspaces

If you see options for UTF-8 and UTF-16, try flipping between the two.

TSU

the same thing also happens if I am to download something from firefox and the filename has such characters

ok, trying out things to fix stuff that has already worked and is now broken (with nobody knowing why) seems to be the sort of solutions one gets these days. Will have to go that way. But I hate it.

I am still not sure that there is somwthing that simply is wrong on your system.

I am running openSUSE13.1 and KDE4, but never encountered the problems you have. As I have shown, I can create and use file names with all sorts of Unicode characters. I can realy not believe that that is lost in openSUSE 13.2 and Plasma5. The forums would be floaded with reports, not only from French users, but from many countries around Europe and the whole world. This does not seem to be the case.

It seems like I have found the solution.

First, my repos may look like a mess for those who do not distinguish between active and non-active repos. Whatever they are, they were not the problem.

Second, the response from tsu2 was the helpful one, directing me to this reddit post, which says

unchecking “Detailed Settings” under System Settings -> Regional Settings -> Format solved the problem for me, it is working properly now.

While this looked like a fix-without-solving-the-problem, I also looked at his/her second suggestion

The problem was that I was using en*GB.UTF-8 in some of the Regional Settings (LC**), however I didn’t have en_GB generated. I have resolved this properly now by un-commenting the en_GB.UTF-8 line in /etc/locale.gen, then running locale-gen command.

but I could not find anything remotely sounding like “locale.gen” on my system.

Anyway, it seems that for now, the characters are interpreted correctly. If someone knows how to properly work again with the detailed format settings, which must be broken, I’d appreciate it.