KDE 4 not rendering correctly with Nvidia Drivers

I need help to find the solution of this problem, I have an openSUSE 11.1 x64 with a Nvidia 7600 GS graphics card and every time I install one of the newer drivers from Nvidia I get this:


The background of the menu and some other applications does not render correctly.

I have tried a lot of diferent drivers like:
NVIDIA-Linux-x86_64-185.18.36-pkg2.run (Newset stable driver)
NVIDIA-Linux-x86_64-190.25-pkg2.run (Beta driver)

and some drivers between those, but the only ones working correctly are the older drivers:

I now how to install them from outside KDE and I tried the ones from the repo with the same results, do you know how to fix this KDE problem? Apparently most of the applications run OK so far, so this might have to do only with KDE.

I have the latest kernel fixes provided automatically from the opensuse updater and I do not normally use factory or beta stuff to avoid this kind of problems.

This problem did not appear when I was using the same hardware but with opensuse 11.1 x86 only with the x64 nvidia drivers.

Thank you in advace.

Go to the yast,and check the repositories once there add community and checkmark nvidia then add. once you have the nvidia repository run a update and make sure the nvidia update is run this will fix some of the problems you are having
the updates from the repositories seems to make the nvidia work better.

I am not sure if I follow your instructions, which community repo should I add? The kde 4 community? In that one I did not find anything about nvidia, using the drivers from the repositories of nvidia get me the same problem.

If you could be so kind to point me to the repositories that you have used or know to fix this please, that would be really helpful.

Doesn’t seems a kde problem…

what about you /etc/xorg.conf?
Have you, maybe, enabled composite ? (bad move)

I would like some info on your system.
what is the model and the brand and what is the graphics card that you have . this will help even more
in the software management area of yast click on the repository heading, once in there you will go to the bottom to the left and click add. a list will come up and check the community then there will be a list of repositories that are available such as ATI,GAMES ,OPEN OFFICE, and NVIDIA should be there. checkmark NVIDIA and hit ok it will then ask you to imprt the certificate click ok and let it finish. once you have that in the system. close the repository window and open the software window , now you want to click repositiories in the search area. once this is open it will show a list of the nvidia drivers that are available and you should be able to locate the one needed for your card.once you download you need to reboot and look in the my computer area and see if nvidia is listed as the graphics card.if everything went right it should be there. let us know