KDE 4 breaks: Could not start kstartupconfig4. Check your ..

On openSUSE 10.3 and 11.0…


After installing KDE4 Desktop from the correct repositories, you attempt to login and encounter a A dialog-box message:

Could not start kstartupconfig4. Check your installation

Next, login to KDE3 desktop, and run:

  # kstartupconfig4

You may see:

  kstartupconfig4: symbol lookup error: /usr/lib/libQtDBus.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv


If the above is your situation then try to un-install the Nessus client.

This worked for me in openSUSE 11.0 and was suggested in this
this blog post for openSUSE 10.3.

Hope that helps?

Thank you for this tip.

I was experiencing a similar issue.
Upon normal booting, I would receive an error message that read something like “Could not start kstartupconfig4. Check your install.”

After looking through the openSUSE forums, I came upon your comment.
I tried the command:


and that revealed an issue with “libQtCore.so.4”.

As a fix, I used:

zypper ve

and that fixed my issue.

Your tip helped me diagnose the issue. I am a newbie with openSUSE, so I wanted to share this info with others that might run into the same situation.