KDE 4 Boot hangs for a while...?

I’m running KDE 4.2 on OpenSUSE 11.1. I noticed that KDE seems to stop booting for a while after I login. The hard drive light doesn’t come on, and the progress bar just stays the way it is. KDE boots up fine if I wait for about 10 seconds. I tried disabling unwanted startup programs, but it didn’t help. I also upgraded from KDE 4.1 to 4.2. Does anyone know where I could look at a few logs to see what KDE is doing when it’s starting up? Anyone else having this problem? thanx.

Yes, I have this problem. It happens every time, and it’s kinda normal. I’ve tried a lot of things, doesn’t matters.
You can try out several hacks but the little delay when hard-drive does nothing still remains there. You can ask for it on kde-forums and if you have spare time you can complain with the moderators but doesn’t worth it.
KDE have a lot of problems compared to the previous versions. You know: It isn’t a bug it’s a “feature”. They are working on it, wait for the patches and updates. Be happy that it’s the only problem with your KDE. :slight_smile:

hey, thanks for your reply. i finally fixed the problem. the bug is with opensuse’s kde splash screen. i replaced it with kde 4.2’s default splash and the hang up is gone. just thought i’d share this…

Good for you then. :slight_smile:
I’m using the default splash and I’m pretty sure that the problem is a bit complicated.